Bug 203674 - java plugin does not launch yahoo stock screener
Summary: java plugin does not launch yahoo stock screener
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Fitzsimmons
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 221426
TreeView+ depends on / blocked
 
Reported: 2006-08-22 23:39 UTC by Rik van Riel
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version: 4.1.2-9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-19 16:15:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rik van Riel 2006-08-22 23:39:38 UTC
Version-Release number of selected component (if applicable):

java-1.4.2-gcj-compat-1.4.2.0-40jpp_100rh

Steps to Reproduce:
1. go to http://screener.finance.yahoo.com/newscreener.html
2. click "Launch Yahoo! Finance Stock Screener"
3. watch no java applet appear
  
Expected results:

The stock screener should start.

Additional info:

This is on x86-64, using firefox.

Comment 1 Thomas Fitzsimmons 2006-08-30 19:31:56 UTC
Yes, looks like a Swing JTable bug.  Re-assigning to Tania Bento.


Comment 2 Thomas Fitzsimmons 2006-09-27 14:23:25 UTC
This is fixed now in GNU Classpath CVS.  We'll close this bug report once we've
backported the fixes to Rawhide libgcj.


Comment 3 Rik van Riel 2006-12-23 17:10:15 UTC
Do you have any idea yet when this fix will be moved into rawhide?

It's been 3 months since the bug has been fixed upstream, but Fedora (and RHEL5)
are still broken :(

Comment 4 Thomas Fitzsimmons 2007-03-07 17:11:16 UTC
We retested this yesterday against the new Rawhide GCC which includes Tania's
fix for the JTable bug.  Unfortunately, the applet hits another bug in libgcj's
java.util.Currency class (the applet works on GNU Classpath's version of this
class).  Tania is going to backport the fix from GNU Classpath to Rawhide.


Comment 5 Tom Tromey 2007-04-05 00:42:26 UTC
I checked her patch in to gcc svn trunk and the RH 4.1 branch.
It is r123513 on the branch.


Comment 6 Thomas Fitzsimmons 2007-04-19 16:15:55 UTC
Fixed in libgcj-4.1.2-9.



Note You need to log in before you can comment on or make changes to this bug.