Bug 203695 - Unknown symbols loading mptspi.ko & could not find filesystem '/dev/root'
Unknown symbols loading mptspi.ko & could not find filesystem '/dev/root'
Status: CLOSED DUPLICATE of bug 203696
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
ia64 Linux
medium Severity high
: ---
: ---
Assigned To: Red Hat Kernel Manager
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-23 05:03 EDT by Fabio Bettoni
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-31 10:24:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabio Bettoni 2006-08-23 05:03:28 EDT
Description of problem:
Starting from kernel-2.6.17-1.2583.fc6 and maybe from kernel-2.6.17-1.257* the 
mptspi.ko is not load cause of Unknown symbols and also /dev/root filesystem 
is not found.


Version-Release number of selected component (if applicable):
kernel-2.6.17-1.2583.fc6

How reproducible:
Installing and bootstrapping kernel-2.6.17-1.2583.fc6

  
Actual results:
Loading mptbase.ko module
Fusion MPT base driver 3.04.01
Copyright (c) 1999-2005 LSI Logic Corporation
Loading scsi_mod.ko module
SCSI subsystem initialized
Loading sd_mod.ko module
Loading scsi_transport_spi.ko module
Loading mptspi.ko module
mptspi: Unknown symbol mptscsih_qcmd
mptspi: Unknown symbol mptscsih_bios_param
mptspi: Unknown symbol mptscsih_io_done
mptspi: Unknown symbol mptscsih_slave_configure
mptspi: Unknown symbol mptscsih_taskmgmt_complete
mptspi: Unknown symbol mptscsih_ioc_reset
mptspi: Unknown symbol mptscsih_remove
mptspi: Unknown symbol mptscsih_bus_reset
mptspi: Unknown symbol mptscsih_proc_info
mptspi: Unknown symbol mptscsih_host_reset
mptspi: Unknown symbol mptscsih_TMHandler
mptspi: Unknown symbol mptscsih_timer_expired
mptspi: Unknown symbol mptscsih_scandv_complete
mptspi: Unknown symbol mptscsih_resume
mptspi: Unknown symbol mptscsih_raid_id_to_num
mptspi: Unknown symbol mptscsih_event_process
mptspi: Unknown symbol mptscsih_suspend
mptspi: Unknown symbol mptscsih_slave_alloc
mptspi: Unknown symbol mptscsih_slave_destroy
mptspi: Unknown symbol mptscsih_change_queue_depth
mptspi: Unknown symbol mptscsih_target_alloc
mptspi: Unknown symbol mptscsih_shutdown
mptspi: Unknown symbol mptscsih_target_destroy
mptspi: Unknown symbol mptscsih_dev_reset
mptspi: Unknown symbol mptscsih_info
mptspi: Unknown symbol mptscsih_abort
insmod: error inserting '/lib/mptspi.ko': -1 Unknown symbol in module

... and later on ...

Loading jbd.ko module
kernel unaligned access to 0xa000000201b2c05f, ip=0xa00000010029c6b1
kernel unaligned access to 0xa000000201b2c067, ip=0xa00000010029c6b1
kernel unaligned access to 0xa000000201b2c06f, ip=0xa00000010029c6b1
kernel unaligned access to 0xa000000201b2c077, ip=0xa00000010029c6b1
kernel unaligned access to 0xa000000201b2c07f, ip=0xa00000010029c6b1
Loading ext3.ko module
Creating root device.
Mounting root filesystem.
mount: could not find filesystem '/dev/root'
Setting up other filesystems.
Setting up new root fs
setuproot: moving /dev failed: No such file or directory
no fstab.sys, mounting internal defaults
setuproot: error mounting /proc: No such filKernel panic - not syncing: 
Attempted to kill init!
e or directory


/etc/modprobe.conf for scsi stuff contains:
alias scsi_hostadapter mptbase
alias scsi_hostadapter1 mptspi
alias scsi_hostadapter1 mptspi
alias scsi_hostadapter2 sym53c8xx
install mptscsih /sbin/modprobe --ignore-install mptscsih
install mptspi /sbin/modprobe --ignore-install mptspi
Comment 1 Prarit Bhargava 2006-08-31 10:24:31 EDT

*** This bug has been marked as a duplicate of 203696 ***

Note You need to log in before you can comment on or make changes to this bug.