Bug 2036973 - SELinux is preventing ModemManager from read, write access on the chr_file wwan0at0.
Summary: SELinux is preventing ModemManager from read, write access on the chr_file ww...
Keywords:
Status: CLOSED DUPLICATE of bug 1961571
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 35
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Zdenek Pytela
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:e74a87de15577dc59091ce6fe12...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-01-04 14:37 UTC by David Auer (2nd Account)
Modified: 2022-01-12 18:21 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-01-12 18:21:55 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description David Auer (2nd Account) 2022-01-04 14:37:20 UTC
Description of problem:
On each boot (ThinkPad L14)
SELinux is preventing ModemManager from read, write access on the chr_file wwan0at0.

*****  Plugin device (91.4 confidence) suggests   ****************************

If you want to allow ModemManager to have read write access on the wwan0at0 chr_file
Then you need to change the label on wwan0at0 to a type of a similar device.
Do
# semanage fcontext -a -t SIMILAR_TYPE 'wwan0at0'
# restorecon -v 'wwan0at0'

*****  Plugin catchall (9.59 confidence) suggests   **************************

If you believe that ModemManager should be allowed read write access on the wwan0at0 chr_file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'ModemManager' --raw | audit2allow -M my-ModemManager
# semodule -X 300 -i my-ModemManager.pp

Additional Information:
Source Context                system_u:system_r:modemmanager_t:s0
Target Context                system_u:object_r:device_t:s0
Target Objects                wwan0at0 [ chr_file ]
Source                        ModemManager
Source Path                   ModemManager
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
SELinux Policy RPM            selinux-policy-targeted-35.7-1.fc35.noarch
Local Policy RPM              selinux-policy-targeted-35.7-1.fc35.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 5.15.12-200.fc35.x86_64 #1 SMP Wed
                              Dec 29 15:03:38 UTC 2021 x86_64 x86_64
Alert Count                   252
First Seen                    2021-10-07 09:00:02 CEST
Last Seen                     2022-01-04 09:00:46 CET
Local ID                      243819de-e975-4e69-937f-6fbc88ed1c2b

Raw Audit Messages
type=AVC msg=audit(1641283246.246:239): avc:  denied  { read write } for  pid=3264 comm="ModemManager" name="wwan0at0" dev="devtmpfs" ino=724 scontext=system_u:system_r:modemmanager_t:s0 tcontext=system_u:object_r:device_t:s0 tclass=chr_file permissive=0


Hash: ModemManager,modemmanager_t,device_t,chr_file,read,write

Version-Release number of selected component:
selinux-policy-targeted-35.7-1.fc35.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.15.2
hashmarkername: setroubleshoot
kernel:         5.15.12-200.fc35.x86_64
type:           libreport

Potential duplicate: bug 1712324

Comment 1 David Auer (2nd Account) 2022-01-04 14:42:30 UTC
Comes in pairs with: #2036972

Comment 2 Zdenek Pytela 2022-01-12 18:21:55 UTC

*** This bug has been marked as a duplicate of bug 1961571 ***


Note You need to log in before you can comment on or make changes to this bug.