Bug 203709 - firefox 1.5.0.6 crashes with acroread plugin
firefox 1.5.0.6 crashes with acroread plugin
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-23 08:38 EDT by Klaus Steinberger
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: firefox-1.5.0.10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-13 02:39:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gdb stack backtrace (9.62 KB, text/plain)
2006-08-23 08:38 EDT, Klaus Steinberger
no flags Details

  None (edit)
Description Klaus Steinberger 2006-08-23 08:38:09 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:

every time viewing an PDF


Steps to Reproduce:
1. Install acroread-7.0.8 plugin
2. Browse to a page with a PDF (e.g.:
http://www.physik.uni-muenchen.de/fakultaet/zentrale_bereiche/geschaeftsstelle/merkblaetter/index.html

3. Click on one of the PDF's
  
Actual results:

Firefox crashes

Expected results:

acroread plugin should open PDF inside the browser window

Additional info:

This bug did not happen with firefox 1.5.0.4, also it do not happen with the
stock firefox from mozilla.org, so it must be somewhere in the fedora patches
against firefox.

Also there seems to be also a problem with Java plugin (SUN JRE), the plugin
shows up in about:plugins, but refuses to start. This bug seems to be related to
the acroread bug, as this started to happen also after 1.5.0.4, and also works
with stock firefox.
Comment 1 Klaus Steinberger 2006-08-23 08:38:10 EDT
Created attachment 134705 [details]
gdb stack backtrace
Comment 2 Klaus Steinberger 2006-09-15 04:04:09 EDT
This bug is not fixed by 1.5.0.7

Also probably related to this bug:

The Sun Java Plugin do not work as expected. The plugin just does nothing. This
can be reproduced by surfing onto the SUN Java testpage:

http://www.java.com/en/download/help/testvm.xml

Please fix this bug asap, it definitly reduces the usability of firefox! And it
is definitly a bug introduces by some Fedora changes, as the stock veron from
mozilla.org did not have this bug.

Sincerly,
Klaus
Comment 3 Marc Wiriadisastra 2006-09-27 20:35:41 EDT
I can agree that java link causes firefox to crash instantly.

Comment 4 Martin Stransky 2007-04-13 02:39:47 EDT
fixed in 1.5.0.10 (caused by too long user agent string)

Note You need to log in before you can comment on or make changes to this bug.