This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 203740 - network install via http from IPv6 server is problem
network install via http from IPv6 server is problem
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Mike McLean
:
Depends On:
Blocks: IPv6Blocker
  Show dependency treegraph
 
Reported: 2006-08-23 11:12 EDT by Peter Vrabec
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: anaconda-11.1.0.104-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-04 06:01:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Vrabec 2006-08-23 11:12:50 EDT
Description of problem:
It seems anaconda doesn't resolve IPv6 host.

How reproducible:
linux askmethod
install from http server
use hostname assigned to IPv6
  
Actual results:
Unable to retrieve
http://knedlo6//store/mirror/fedora/development/i386/os/repodata/repomd.xml

>>> cannot determine address family of knedlo6
>>> we don't have reverse DNS for IPv6 yet

Additional info:
Installation works when I use IPv6 address of the host.
Comment 2 David Cantrell 2006-09-01 10:28:40 EDT
Installation from an IPv6 HTTP server *does* work.  What doesn't work is exactly
what's in the error message: reverse DNS.  We have our own resolver in the
loader and I have not yet expanded it to support IPv6 name resolution.  It's on
my list and will be done in time for FC-6.

Try installation with the IPv6 address of the server rather than the hostname.
Comment 3 Peter Vrabec 2006-10-04 06:01:56 EDT
it seems to be fixed in anaconda-11.1.0.104-1

Note You need to log in before you can comment on or make changes to this bug.