Bug 203746 - crond should use Auto-Submitted header in outbound mail
crond should use Auto-Submitted header in outbound mail
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: vixie-cron (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-23 11:28 EDT by James Ralston
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-25 05:19:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
make crond generated the Auto-Submitted header on mail messages (499 bytes, patch)
2006-08-23 11:28 EDT, James Ralston
no flags Details | Diff

  None (edit)
Description James Ralston 2006-08-23 11:28:44 EDT
Created attachment 134726 [details]
make crond generated the Auto-Submitted header on mail messages
Comment 1 James Ralston 2006-08-23 11:28:44 EDT
RFC3834 (Recommendations for Automatic Responses to Electronic Mail)
makes recommendations for software that automatically responds to
incoming electronic mail messages.  Specifically, RFC3834 defines an
"Auto-Submitted" header that compliant software can use to indicate that a
message has been automatically generated.

Section 5.2 states:

> The auto-generated keyword:
> 
> - SHOULD be used on messages generated by automatic (often periodic)
>   processes (such as UNIX "cron jobs") which are not direct
>   responses to other messages,

Meaning, crond should generate an "Auto-Submitted: auto-generated" header on
each mail message it generates.  Currently, vixie-cron does not do this.

The attached patch makes vixie-cron conform to RFC3834 by generating the
recommended Auto-Submitted header.  It applies cleanly to 4:4.1-58.
Comment 2 James Ralston 2006-08-23 11:34:20 EDT
Also note that I've filed this bug against FC6test2, but it affects all versions
of Fedora Core and Red Hat Enterprise Linux, and should be corrected everywhere
(FC5, FC6, RHEL2.1, RHEL3, RHEL4).
Comment 3 Marcela Mašláňová 2006-08-25 05:19:03 EDT
I fix it in FC-5 update, FC-6. For RHEL it'll be fixed in future release 
because it's incompatible change.
Comment 4 James Ralston 2006-08-25 23:23:57 EDT
For FC: thanks.

For RHEL: when you say "future releases", do you mean future update releases
(e.g., RHEL3 U9, RHEL4 U5), or do you mean that something about this change
means that it will have to wait for RHEL5?

If the latter, then just out of curiosity: why?

Note You need to log in before you can comment on or make changes to this bug.