This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 203748 - [as_IN] font failed to match
[as_IN] font failed to match
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: fontconfig (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
: i18n
Depends On:
Blocks: Indic
  Show dependency treegraph
 
Reported: 2006-08-23 11:37 EDT by A S Alam
Modified: 2013-07-02 20:39 EDT (History)
2 users (show)

See Also:
Fixed In Version: fontconfig-2.4.1-2.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-28 05:07:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 8050 None None None Never

  None (edit)
Description A S Alam 2006-08-23 11:37:26 EDT
Description of problem:
LANG=as_IN.UTF-8 fc-match

Version-Release number of selected component (if applicable):
fonts-bengali-2.0.1-1

How reproducible:
Everytime

Steps to Reproduce:
1. run above command
2.
3.
  
Actual results:
DejaVuLGCSans.ttf: "DejaVu LGC Sans" "Book"

Expected results:
some fonts for Lohit
Comment 1 Lawrence Lim 2006-08-23 20:23:42 EDT
Reassigning to the more appropriate component. Prolly need to reassign
maintainer too.
Comment 2 Leon Ho 2006-08-28 02:51:32 EDT
Smell like a fontconfig problem, as the required codepoints in Bengali are
exactly the same as Assamese. Reassigning to fontconfig.
Comment 3 Behdad Esfahbod 2006-09-01 16:40:21 EDT
"Created as.orth which references bn.orth" upstream.  Will be in next upgrade of
fontconfig.
Comment 4 Akira TAGOH 2006-09-27 07:44:23 EDT
looks like working fine now.

$ rpm -q fonts-bengali fontconfig
fonts-bengali-2.0.2-1
fontconfig-2.4.1-2.fc6
$ LANG=as_IN.UTF-8 fc-match
lohit_bn.ttf: "Lohit Bengali" "Regular"

changing to MODIFIED.
Comment 5 Nicole Dai 2006-09-28 05:07:27 EDT
Confirmed it has been fixed in latest FC6:
# rpm -q fonts-bengali fontconfig
fonts-bengali-2.0.2-1
fontconfig-2.4.1-2.fc6
# LANG=as_IN.UTF-8 fc-match
lohit_bn.ttf: "Lohit Bengali" "Regular"

Note You need to log in before you can comment on or make changes to this bug.