Bug 2037496 - CNO: verify job is broken since yaml-patch has disappeared
Summary: CNO: verify job is broken since yaml-patch has disappeared
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.9
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.10.0
Assignee: Ben Bennett
QA Contact: zhaozhanqi
URL:
Whiteboard:
Depends On:
Blocks: 2037499
TreeView+ depends on / blocked
 
Reported: 2022-01-05 18:21 UTC by Maysa Macedo
Modified: 2022-01-05 18:28 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 2037499 (view as bug list)
Environment:
Last Closed: 2022-01-05 18:28:23 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Maysa Macedo 2022-01-05 18:21:36 UTC
Description of problem:

The verify job has been failing reporting the following message:
 mkdir -p '_output/tools/bin/'
curl -s -f -L https://github.com/krishicks/yaml-patch/releases/download/v0.0.10/yaml_patch_linux -o '_output/tools/bin/yaml-patch'
make: *** [ensure-yaml-patch] Error 22 

This is happening because yaml-patch no long exists. To fix it the build-machinery-go dependency needs to be bumped since it already fixed[1] the issue.

[1] https://github.com/openshift/build-machinery-go/pull/58

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:


Note You need to log in before you can comment on or make changes to this bug.