Bug 203762 - services are not switched properly across nodes
Summary: services are not switched properly across nodes
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rgmanager (Show other bugs)
(Show other bugs)
Version: 5.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Lon Hohberger
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 206292
TreeView+ depends on / blocked
 
Reported: 2006-08-23 17:01 UTC by Fabio Massimo Di Nitto
Modified: 2009-04-16 22:35 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-27 18:59:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Fabio Massimo Di Nitto 2006-08-23 17:01:44 UTC
Version-Release number of selected component (if applicable):

latest CVS checkout as of 2006/08/23 at 10am UTC

How reproducible:

99.9% of the time.

Steps to Reproduce:
1. setup a 2 nodes cluster
2. configure one failover domain with one shared ip service
3. start the cluster, make sure the cluster is formed and quorated
4. start rgmanager on both the nodes
5. make sure the shared ip service is started and rgmangares are running properly.
6. stop rgmanager on the node that owns the service
  
Actual results:

the service is not migrated on the other node

Expected results:

the service should migrate to the other node

Additional info:

Only one time it did happen that the service was actually migrated
but nothing different from the other times was done.

No special messages are left in daemons.log.

Lon if you need anything like logs or configs, please let me know.
The cluster is running ipv4 all over. No ipv6 involved yet.

Fabio

Comment 1 Lon Hohberger 2006-08-24 17:29:49 UTC
After being unable to reproduce this, I just noticed that I need a failover
domain.  ;)

Could you post your config when you get a chance?  



Comment 2 Fabio Massimo Di Nitto 2006-08-25 07:00:18 UTC
http://people.ubuntu.com/~fabbione/cluster.conf2

there you go :)

Fabio

Comment 3 Nate Straz 2007-12-13 17:19:08 UTC
Moving all RHCS ver 5 bugs to RHEL 5 so we can remove RHCS v5 which never existed.


Note You need to log in before you can comment on or make changes to this bug.