Bug 203772 - rpm cannot install .src.rpm due to missing /usr/src/redhat
rpm cannot install .src.rpm due to missing /usr/src/redhat
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-23 13:45 EDT by Will Woods
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-23 14:29:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Will Woods 2006-08-23 13:45:30 EDT
rpm is normally able to install .src.rpm files. However the rpm package does not
own /usr/src/redhat - rpm-build does.

Without this directory, attempting to install a .src.rpm fails with:
error: cannot create %sourcedir /usr/src/redhat/SOURCES

Creating /usr/src/redhat allows the .src.rpm to be installed.

This bug has been present since FC5.
Comment 1 Will Woods 2006-08-23 14:29:38 EDT
Solution: install rpm-build. You need this to do anything useful with the
contents of the .src.rpm anyway.

If you don't want to wait that long, just do: 
 mkdir /usr/src/redhat
and try again.

Note You need to log in before you can comment on or make changes to this bug.