Bug 2037776 - OCP builds always fail when run on RHEL7 nodes
Summary: OCP builds always fail when run on RHEL7 nodes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Build
Version: 4.9
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: ---
: 4.9.z
Assignee: Nalin Dahyabhai
QA Contact: Jitendar Singh
URL:
Whiteboard:
: 2026589 (view as bug list)
Depends On: 1979966
Blocks: 2026589
TreeView+ depends on / blocked
 
Reported: 2022-01-06 14:54 UTC by OpenShift BugZilla Robot
Modified: 2022-01-17 08:07 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
job=periodic-ci-openshift-release-master-nightly-4.9-e2e-aws-workers-rhel7=all
Last Closed: 2022-01-17 08:07:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift builder pull 279 0 None Merged [release-4.9] Bug 2037776: Update containers/storage to address incorrect overlay options being set on rhel7 nodes 2022-01-11 07:31:24 UTC
Red Hat Product Errata RHBA-2022:0110 0 None None None 2022-01-17 08:07:49 UTC

Comment 1 Adam Kaplan 2022-01-06 15:04:55 UTC
*** Bug 2026589 has been marked as a duplicate of this bug. ***

Comment 5 Jitendar Singh 2022-01-12 06:54:18 UTC
verified using the fix found in https://openshift-release.apps.ci.l2s4.p1.openshiftapps.com/releasestream/4.9.0-0.nightly/release/4.9.0-0.nightly-2022-01-07-212215
===================================

1. Create a project testing-rhel

2. applied buildconfig with nodeSelector node.openshift.io/os_id: rhel

buildconfig.yaml
apiVersion: build.openshift.io/v1
kind: BuildConfig
metadata:
  name: example
  namespace: testing-rhel
spec:
  nodeSelector:
    node.openshift.io/os_id: rhel
  source:
    git:
      ref: master
      uri: 'https://github.com/openshift/ruby-ex.git'
    type: Git
  strategy:
    type: Source
    sourceStrategy:
      from:
        kind: ImageStreamTag
        name: 'ruby:2.7'
        namespace: openshift
      env: []
  triggers:
    - type: ImageChange
      imageChange: {}
    - type: ConfigChange

3. Builds gets completed
$ oc get builds
NAME        TYPE     FROM          STATUS     STARTED          DURATION
example-1   Source   Git@01effef   Complete   54 seconds ago   54s

$ oc get bc
NAME      TYPE     FROM         LATEST
example   Source   Git@master   1

$ oc get pods -o wide
NAME              READY   STATUS      RESTARTS   AGE   IP            NODE                       NOMINATED NODE   READINESS GATES
example-1-build   0/1     Completed   0          69s   10.129.2.59   jshjs-lshvl-w-a-l-rhel-1   <none>           <none>

$ oc logs pod/example-1-build
time="2022-01-12T12:09:53Z" level=info msg="metacopy [...]
"/var/cache/blobs".
Trying to pull image-registry.openshift-image-registry.svc:5000/openshift/ruby@sha256:19f0b4c21e1b5e77d5442515719a543d0dca5c6b7f57bfaeea8c5e100ae63232...
Getting image source signatures
Copying blob sha256:b46ca46c303b49d886a7585735ebd1dc8651e83d0fab5823300cf3a9fd2febc1
Copying blob sha256:ac08ca107ad9ed699cbd28339749dd6463a84c73aa1d468a4241385fc4ec3876
[...]
Writing manifest to image destination
Storing signatures
Generating dockerfile with builder image image-registry.openshift-image-registry.svc:5000/openshift/ruby@sha256:19f0b4c21e1b5e77d5442515719a543d0dca5c6b7f57bfaeea8c5e100ae63232
Adding transient rw bind mount for /run/secrets/rhsm
Adding transient rw bind mount for /run/secrets/redhat.repo
STEP 1/9: FROM image-registry.openshift-image-registry.svc:5000/openshift/ruby@sha256:19f0b4c21e1b5e77d5442515719a543d0dca5c6b7f57bfaeea8c5e100ae63232
time="2022-01-12T12:10:18Z
:07Z" level=warning msg="Ignoring global metacopy option, not supported with booted kernel"
STEP 2/9: LABEL "io.openshift.build.image"="image-registry.openshift-image-registry.svc:5000/openshift/ruby@sha256:19f0b4c21e1b5e77d5442515719a543d0dca5c6b7f57bfaeea8c5e100ae63232"       "io.openshift.build.commit.author"="Honza Horak <hhorak@redhat.com>"       "io.openshift.build.commit.date"="Fri Aug 21 13:44:47 2020 +0200"       "io.openshift.build.commit.id"="01effef3a23935c1a83110d4b074b0738d677c44"       "io.openshift.build.commit.ref"="master"       "io.openshift.build.commit.message"="Merge pull request #35 from pvalena/bundler"       "io.openshift.build.source-location"="https://github.com/openshift/ruby-ex.git"
STEP 3/9: ENV OPENSHIFT_BUILD_NAME="example-1"     OPENSHIFT_BUILD_NAMESPACE="testing-rhel"     OPENSHIFT_BUILD_SOURCE="https://github.com/openshift/ruby-ex.git"     OPENSHIFT_BUILD_REFERENCE="master"     OPENSHIFT_BUILD_COMMIT="01effef3a23935c1a83110d4b074b0738d677c44"
STEP 4/9: USER root
STEP 5/9: COPY upload/src /tmp/src
STEP 6/9: RUN chown -R 1001:0 /tmp/src
STEP 7/9: USER 1001
STEP 8/9: RUN /usr/libexec/s2i/assemble
---> Installing application source ...
---> Building your Ruby application from source ...
---> Running 'bundle install --retry 2 --deployment --without development:test' ...
[DEPRECATED] The `--deployment` flag is deprecated because it relies on being remembered across bundler invocations, which bundler will no longer do in future versions. Instead please use `bundle config set --local deployment 'true'`, and stop using this flag
[DEPRECATED] The `--path` flag is deprecated because it relies on being remembered across bundler invocations, which bundler will no longer do in future versions. Instead please use `bundle config set --local path './bundle'`, and stop using this flag
[DEPRECATED] The `--without` flag is deprecated because it relies on being remembered across bundler invocations, which bundler will no longer do in future versions. Instead please use `bundle config set --local without 'development:test'`, and stop using this flag
Fetching gem metadata from https://rubygems.org/
Fetching gem metadata from https://rubygems.org/..
Fetching gem metadata from https://rubygems.org/..
Using bundler 2.2.24
Fetching nio4r 2.5.2
Fetching rack 2.2.3
Installing nio4r 2.5.2 with native extensions
Installing rack 2.2.3
Fetching puma 4.3.5
Installing puma 4.3.5 with native extensions
Bundle complete! 2 Gemfile dependencies, 4 gems now installed.
Gems in the groups 'development' and 'test' were not installed.
Bundled gems are installed into `./bundle`
---> Cleaning up unused ruby gems ...
Running `bundle clean --verbose` with bundler 2.2.24
Frozen, using resolution from the lockfile
STEP 9/9: CMD /usr/libexec/s2i/run
COMMIT temp.builder.openshift.io/testing-rhel/example-1:c434382c
time="2022-01-12T12:10:18Z" level=warning msg="Ignoring global metacopy option, not supported with booted kernel"
Getting image source signatures
Copying blob sha256:cc423b2000aec40199a4f4e1012f2e9b573d4ce6bc1ca416a598f8e1d45f3d13
Copying blob sha256:41d099875e8768dcadb9f7e388d68c50eb25f6160c8a3858b966d12d89e4d288
Copying blob sha256:3cd3b63408eccc3f9a1ffb740cf311d927927f94247e952af1c9b67c1ad2db4f
Copying blob sha256:3dca2e66497972abbd6a7796a701296ada6bb53013b52d4432bc0d3f1cf0e7bd
Copying blob sha256:83b76fb61d8095ec96901a654c78ecb24246378f905d96eb152348af72089f70
Copying blob sha256:f008aacb05a5e87c49ca50c5f5ac03b6c1b633f38249ed0617e984381b426c27
Copying config sha256:0c3c9936d566ecca29f4e8b92dfcceca341d632056ff056e628a1f612fe7f50b
Writing manifest to image destination
Storing signatures
--> 0c3c9936d56
Successfully tagged temp.builder.openshift.io/testing-rhel/example-1:c434382c
0c3c9936d566ecca29f4e8b92dfcceca341d632056ff056e628a1f612fe7f50b
Build complete, no image push requested

Comment 7 errata-xmlrpc 2022-01-17 08:07:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.9.15 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2022:0110


Note You need to log in before you can comment on or make changes to this bug.