Bug 2037901
| Summary: | Show available orgs before prompting for input in syspurpose subcommands | ||
|---|---|---|---|
| Product: | Red Hat Enterprise Linux 8 | Reporter: | Chris Snyder <csnyder> |
| Component: | subscription-manager | Assignee: | candlepin-bugs |
| Status: | CLOSED ERRATA | QA Contact: | Red Hat subscription-manager QE Team <rhsm-qe> |
| Severity: | low | Docs Contact: | |
| Priority: | medium | ||
| Version: | 8.6 | CC: | csnyder, jhnidek, jsefler, mhorky, redakkan, rhsm-qe, zpetrace |
| Target Milestone: | rc | Keywords: | Triaged |
| Target Release: | --- | Flags: | pm-rhel:
mirror+
|
| Hardware: | Unspecified | ||
| OS: | Unspecified | ||
| Whiteboard: | |||
| Fixed In Version: | subscription-manager-1.28.25-1.el8 | Doc Type: | If docs needed, set a value |
| Doc Text: | Story Points: | --- | |
| Clone Of: | 2003777 | Environment: | |
| Last Closed: | 2022-05-10 15:22:58 UTC | Type: | Bug |
| Regression: | --- | Mount Type: | --- |
| Documentation: | --- | CRM: | |
| Verified Versions: | Category: | --- | |
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |
| Cloudforms Team: | --- | Target Upstream Version: | |
| Embargoed: | |||
| Bug Depends On: | 2003777 | ||
| Bug Blocks: | |||
Version:
[root@kvm-01-guest15 ~]# subscription-manager version
server type: This system is currently not registered.
subscription management server: 3.2.12-1
subscription management rules: 5.41
subscription-manager: 1.28.25-1.el8
Verification:
[root@kvm-01-guest15 ~]# subscription-manager syspurpose role --list --username=testuser1 --org=admin
Error: you must register or specify --username and --password to list role
[root@kvm-01-guest15 ~]# subscription-manager syspurpose role --list --username=testuser1 --org=admin --password=password
+-------------------------------------------+
Available role
+-------------------------------------------+
- SP Starter
- SP Server
[root@kvm-01-guest15 ~]# subscription-manager syspurpose role --list --username=testuser1 --org=xxxxxx
Error: you must register or specify --username and --password to list role
[root@kvm-01-guest15 ~]# subscription-manager syspurpose role --list --username=testuser1 --org=xxxxx --password=password
Organization with id xxxxx could not be found. (HTTP error code 404: Not Found)
[root@kvm-01-guest15 ~]# subscription-manager orgs --username=testuser1 --password=password
+-------------------------------------------+
testuser1 Organizations
+-------------------------------------------+
Name: Snow White
Key: snowwhite
Name: Admin Owner
Key: admin
[root@kvm-01-guest15 ~]# subscription-manager role --list --username=testuser1 --password=password
Hint: User "testuser1" is member of following organizations: snowwhite, admin
Organization: snowwhite
+-------------------------------------------+
Available role
+-------------------------------------------+
- SP Starter
- SP Server
[root@kvm-01-guest15 ~]# subscription-manager syspurpose role --list --username=testuser1 --password=password
Hint: User "testuser1" is member of following organizations: snowwhite, admin
Organization: admin
+-------------------------------------------+
Available role
+-------------------------------------------+
- SP Starter
- SP Server
[root@kvm-01-guest15 ~]# subscription-manager orgs --username=mickey --password=password
+-------------------------------------------+
mickey Organizations
+-------------------------------------------+
Name: Donald Duck
Key: donaldduck
[root@kvm-01-guest15 ~]# subscription-manager syspurpose role --list --username=mickey --password=password
+-------------------------------------------+
Available role
+-------------------------------------------+
- SP Starter
- SP Server
[root@kvm-01-guest15 ~]# subscription-manager role --list --username=mickey --password=password
+-------------------------------------------+
Available role
+-------------------------------------------+
- SP Starter
- SP Server
--> verification PASSED
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. For information on the advisory (subscription-manager bug fix and enhancement update), and where to find the updated files, follow the link below. If the solution does not work for you, open a new bug report. https://access.redhat.com/errata/RHBA-2022:2047 |
Pretesting the following subscription-manager build using a standalone candlepin server with TESTDATA deployed... [root@ibm-x3650m4-01-vm-11 ~]# rpm -q subscription-manager subscription-manager-1.28.25-1.el8.x86_64 [root@ibm-x3650m4-01-vm-11 ~]# rpm -q subscription-manager --changelog | grep 2037901 - 2037901: Fix organizations hint in syspurpose commands (mhorky) - 2037901: Only hint organizations if it's needed (mhorky) - 2037901: Show available organizations before asking for input [root@ibm-x3650m4-01-vm-11 ~]# subscription-manager syspurpose role --list --username=testuser1 --org=admin Error: you must register or specify --username and --password to list role <============ PASSED: NEGATIVE TEST [root@ibm-x3650m4-01-vm-11 ~]# subscription-manager syspurpose role --list --username=testuser1 --org=admin --password=password +-------------------------------------------+ <============ PASSED: POSITIVE TEST WITH --ORG Available role +-------------------------------------------+ - SP Starter - SP Server [root@ibm-x3650m4-01-vm-11 ~]# subscription-manager syspurpose role --list --username=testuser1 --org=INVALID Error: you must register or specify --username and --password to list role <============ PASSED: NEGATIVE TEST [root@ibm-x3650m4-01-vm-11 ~]# subscription-manager syspurpose role --list --username=testuser1 --org=INVALID --password=password Organization with id INVALID could not be found. (HTTP error code 404: Not Found) <============ PASSED: NEGATIVE TEST [root@ibm-x3650m4-01-vm-11 ~]# subscription-manager orgs --username=testuser1 --password=password +-------------------------------------------+ testuser1 Organizations +-------------------------------------------+ Name: Snow White Key: snowwhite Name: Admin Owner Key: admin [root@ibm-x3650m4-01-vm-11 ~]# subscription-manager role --list --username=testuser1 --password=password Hint: User "testuser1" is member of following organizations: snowwhite, admin <============ PASSED: HELPFUL ORG HINT Organization: INVALID Organization with id INVALID could not be found. (HTTP error code 404: Not Found) [root@ibm-x3650m4-01-vm-11 ~]# subscription-manager role --list --username=testuser1 --password=password Hint: User "testuser1" is member of following organizations: snowwhite, admin <============ PASSED: HELPFUL ORG HINT Organization: admin +-------------------------------------------+ Available role +-------------------------------------------+ - SP Starter - SP Server [root@ibm-x3650m4-01-vm-11 ~]# subscription-manager syspurpose role --list --username=testuser1 --password=password Hint: User "testuser1" is member of following organizations: snowwhite, admin <============ PASSED: HELPFUL ORG HINT Organization: INVALID Organization with id INVALID could not be found. (HTTP error code 404: Not Found) [root@ibm-x3650m4-01-vm-11 ~]# subscription-manager syspurpose role --list --username=testuser1 --password=password Hint: User "testuser1" is member of following organizations: snowwhite, admin <============ PASSED: HELPFUL ORG HINT Organization: admin +-------------------------------------------+ Available role +-------------------------------------------+ - SP Starter - SP Server [root@ibm-x3650m4-01-vm-11 ~]# subscription-manager orgs --username=mickey --password=password +-------------------------------------------+ mickey Organizations +-------------------------------------------+ Name: Donald Duck Key: donaldduck [root@ibm-x3650m4-01-vm-11 ~]# subscription-manager role --list --username=mickey --password=password +-------------------------------------------+ <============ PASSED: ORG HINT WAS NOT NEEDED Available role +-------------------------------------------+ - SP Starter - SP Server [root@ibm-x3650m4-01-vm-11 ~]# subscription-manager syspurpose role --list --username=mickey --password=password +-------------------------------------------+ <============ PASSED: ORG HINT WAS NOT NEEDED Available role +-------------------------------------------+ - SP Starter - SP Server Verified:Tested syspurpose shows available orgs as hints when needed (when the user has access to more than one org) before interactively prompting for an org