Bug 2038247 - trim redundant configure-options from spec-file
Summary: trim redundant configure-options from spec-file
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xterm
Version: rawhide
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Tomas Korbar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-01-07 16:01 UTC by Thomas E. Dickey
Modified: 2022-01-14 13:26 UTC (History)
2 users (show)

Fixed In Version: xterm-370-2.fc36
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-01-14 13:26:18 UTC
Type: Bug


Attachments (Terms of Use)

Description Thomas E. Dickey 2022-01-07 16:01:05 UTC
Description of problem: the spec-file uses configure options which are redundant, leading to misinterpretation by packager when making changes.

Three options are redundant because they repeat the default values which are several years old:

1.319        (tom      04-Aug-13):      [enable_wchar=yes])
1.349        (tom      25-Dec-17):              [enable_256_color=yes])
1.369        (tom      25-Jul-20):      [enable_sixel_graphics=yes])

This was noticed in making notes for #2038135 (the relevant option dates back to 2013).

Version-Release number of selected component (if applicable): 370


How reproducible:

read the INSTALL file which comes in xterm's source.

Actual results:

The spec-file is longer than necessary.

Expected results:

When making changes, refer to INSTALL.


Additional info:

Comment 1 Fedora Update System 2022-01-14 13:25:10 UTC
FEDORA-2022-acba7cc8d9 has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-acba7cc8d9

Comment 2 Fedora Update System 2022-01-14 13:26:18 UTC
FEDORA-2022-acba7cc8d9 has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.