Bug 203828 - Change from /etc/mono/config to use /etc/mono/conf.d
Change from /etc/mono/config to use /etc/mono/conf.d
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mono (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Xavier Lamien
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-23 17:38 EDT by Paul F. Johnson
Modified: 2013-01-09 23:02 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-20 07:59:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul F. Johnson 2006-08-23 17:38:43 EDT
Description of problem:
As it stands, mono only has one config file. There are a number of packages
available for mono which requires changes to the config files (such as sdldotnet
and db4o). For these, it means that the packager has to add to the config file
directly and then remove as well as part of the spec file.

This is very dangerous.

Would it be possible to have something analigous to httpd with a conf.d
directory which is read by mono? It would make packaging for mono a damned sight
easier and safer.

This is currently not happening upstream, but then neither was getting mono to
be architecture agnostic with _libdir!
Comment 1 Toshio Kuratomi 2006-08-23 21:35:45 EDT
What are you trying to place into the config file? dllmap entries [1]_?  Why not
put them into a per dll config file? [2]_

[1]_ http://www.mono-project.com/DllMap
[2]_ From man mono-config:
       For   each   assembly   loaded   a   config   file   with   the   name:
       /path/to/the/assembly.exe.config is loaded, too.
Comment 2 Bug Zapper 2008-05-13 22:18:10 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Paul F. Johnson 2008-10-20 07:59:40 EDT
I'm going to close this bug - /mono/config seems to be fine...

Note You need to log in before you can comment on or make changes to this bug.