Bug 203852 - Cannot display Chinese Simplified correctly in Kopete and Gaim
Summary: Cannot display Chinese Simplified correctly in Kopete and Gaim
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kdenetwork (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords: i18n
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-08-24 01:18 UTC by Nicole Dai
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-18 14:39:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot-Buddy List.png (13.58 KB, image/png)
2006-08-24 01:18 UTC, Nicole Dai
no flags Details
Screenshot-Kopete.png (17.09 KB, image/png)
2006-08-24 01:19 UTC, Nicole Dai
no flags Details
it works for me (19.68 KB, image/png)
2006-09-18 12:47 UTC, Ngo Than
no flags Details

Description Nicole Dai 2006-08-24 01:18:30 UTC
Description of problem:
Cannot display Chinese Simplified correctly in Kopete and Gaim (maybe more apps
have the problem but I am not sure). Pls refer to attached screenshot for details.

Version-Release number of selected component (if applicable):

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
The problem was not found in RHEL5.

Comment 1 Nicole Dai 2006-08-24 01:18:31 UTC
Created attachment 134762 [details]
Screenshot-Buddy List.png

Comment 2 Nicole Dai 2006-08-24 01:19:13 UTC
Created attachment 134763 [details]
Screenshot-Kopete.png

Comment 3 Akira TAGOH 2006-08-24 13:19:43 UTC
can you provide more details? what version of kopete and gaim has a problem and
what version of them are no problem?

Also since they uses different toolkit and there are no common way to deal with,
even if you may see a lot of problems on a lot of applications, it should be
filed as separate bugs.

Comment 4 Nicole Dai 2006-08-25 00:51:00 UTC
Thank you for your kindly reminder. The problem was found in:
kdenetwork-3.5.4-2.fc6
gaim-2.0.0-0.11.beta3.fc6


Comment 5 Leon Ho 2006-08-28 05:39:14 UTC
A problem you may have non-UTF-8 ICQ nickname? Can you test with an test account
with other chat protocol or enter a nickname using the input method again?

Comment 6 Nicole Dai 2006-08-31 05:34:24 UTC
There is the same problem in kopete with MSN account but no problem in gaim with
MSN account.

Comment 7 Akira TAGOH 2006-08-31 06:39:50 UTC
reassigning to kdenetwork for kopete.

Comment 8 Ngo Than 2006-09-18 11:42:58 UTC
Nicole, does the problem occur with IRC protocol?

Comment 9 Ngo Than 2006-09-18 12:47:11 UTC
Created attachment 136538 [details]
it works for me

i have created new test account and entered the Group/Nick name (aa ab ac) 
using scim->M17n-zh-quick. It displays the Chinese Simplified correctly.

Comment 10 Ngo Than 2006-09-18 12:49:28 UTC
you should please update to new KDE in rawhide

kdelibs-3.5.4-6.fc6
kdebase-3.5.4-7.fc6
kdenetwork-3.5.4-4.fc6


Note You need to log in before you can comment on or make changes to this bug.