Bug 203882 - Hangul input bug on Input line in oocalc
Hangul input bug on Input line in oocalc
Status: CLOSED DUPLICATE of bug 222779
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-24 02:49 EDT by Jong Bae KO
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-24 04:09:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 67316 None None None Never

  None (edit)
Description Jong Bae KO 2006-08-24 02:49:22 EDT
Description of problem:
when you type Hangul in input line, and press accept button. Hangul input is
disappeared. It shows only last Hangul character.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. type "gksrmf(한글)"" in Input line
2. click  Accept(Funchtion) button
3.  
  
Actual results 1:
글

Expected results 1:
한글

Actual results 2:
이

Expected reults 2:
동해물과 백수산이

Additional info:
The character(글) is remained in buffer. So when you click the other empty
cells, it shows the Hangul char(글).
Comment 1 Caolan McNamara 2006-08-24 04:09:16 EDT
When you click accept all the text that has been typed into the input line is
placed into the cell.

But you have clicked accept while still "currently pre-editing" the second
character, so the second character doesn't really exist yet in the input line
only the first character has really been typed. You can see similiar sort of
behaviour in e.g. gedit if you are still in pre-edit mode on the second
character and and use e.g. file->select all->copy and open another gedit and
paste, only the first "finished" character gets pasted into the 2nd gedit

So if you press the right arrow key to finish the character and then press
accept the right thing happens. 

The jumping around of the uncommitted preedit buffer to follow the current input
cell is something we need to address, and is logged upstream as
http://qa.openoffice.org/issues/show_bug.cgi?id=67316

We should also consider having accept clicked equivalent to a signal to commit
the currently being-edited characters.
Comment 2 Jong Bae KO 2006-08-24 22:30:28 EDT
"currently pre-editing" might be big problem. I have to file the gedit bug as well.
Comment 3 Caolan McNamara 2007-01-25 07:54:18 EST

*** This bug has been marked as a duplicate of 222779 ***

Note You need to log in before you can comment on or make changes to this bug.