Bug 2038838 - install evolution error, some packages alread installed
Summary: install evolution error, some packages alread installed
Keywords:
Status: NEW
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution-data-server
Version: 35
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Milan Crha
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-01-10 09:37 UTC by jpbn
Modified: 2022-11-29 17:37 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:
Type: Bug


Attachments (Terms of Use)

Description jpbn 2022-01-10 09:37:43 UTC
Description of problem:
testing new version of evolution from test repository
Want to install evolution to test 
but error:   Testing changes... Failed to install packages: Error running transaction: package evolution-data-server-langpacks-3.42.3-1.fc35.noarch is already installed
package evolution-data-server-3.42.3-1.fc35.x86_64 is already installed


Version-Release number of selected component (if applicable):
3.42

How reproducible:
install evolution (fedora 35 gnome)

Steps to Reproduce:
1.
2.
3.

Actual results:

error
Expected results:
install

Additional info:

Comment 1 Milan Crha 2022-01-10 09:45:45 UTC
Thanks for a bug report. I tried it here as follows and it worked correctly. Could you specify what exactly you've done, please?

I've done this:

$ sudo dnf update evolution --enablerepo=updates-testing
Last metadata expiration check: 0:00:17 ago on Mon 10 Jan 2022 10:43:25 AM CET.
Dependencies resolved.
================================================================================
 Package                          Arch    Version        Repository        Size
================================================================================
Upgrading:
 evolution                        x86_64  3.42.3-1.fc35  updates-testing  3.7 M
 evolution-data-server            x86_64  3.42.3-1.fc35  updates-testing  2.2 M
 evolution-data-server-langpacks  noarch  3.42.3-1.fc35  updates-testing  1.3 M
 evolution-langpacks              noarch  3.42.3-1.fc35  updates-testing  5.5 M

Transaction Summary
================================================================================
Upgrade  4 Packages

Total download size: 13 M
Is this ok [y/N]: y
Downloading Packages:
....
Upgraded:
  evolution-3.42.3-1.fc35.x86_64                                                
  evolution-data-server-3.42.3-1.fc35.x86_64                                    
  evolution-data-server-langpacks-3.42.3-1.fc35.noarch                          
  evolution-langpacks-3.42.3-1.fc35.noarch                                      

Complete!

Comment 2 jpbn 2022-01-10 12:48:11 UTC
I do upgrades testing.
after the fedora-easy-karma command there are two evolution updates (server and server-langpacks) to test.

In a new terminal I give the evolution command, (evolution is not on my machine)
terminal asks me if it should install evolution.
Yes,
and than the install halts with the error as mentioned.

Comment 3 Milan Crha 2022-01-10 13:28:03 UTC
Okay, thanks. Unfortunately, I hear of the fedora-easy-karma for the first time.

What exact commands are you running, with what arguments, please? Also, how did the evolution-data-server-langpacks get installed on your machine, please?

If you do not use the dnf command directly, or you pass it to install the advisory, then it's a problem of the command you use to install to specify also already installed packages on "the command line" of the dnf, in which case the dnf rejects the install with the error you see.

I can reproduce the error simply by running dnf as:

   $ sudo dnf install evolution-data-server
   Last metadata expiration check: 3:06:58 ago on Mon 10 Jan 2022 11:14:41 AM CET.
   Package evolution-data-server-3.42.3-1.fc35.x86_64 is already installed.
   Dependencies resolved.
   Nothing to do.
   Complete!

When I try to update the package with only the evolution-data-server packages installed, I get a success after running:

   $ sudo dnf update --advisory FEDORA-2022-f90519fad7

which installs (updates) only the evolution packages and nothing else.

Would you mind to revert your negative karma at:
https://bodhi.fedoraproject.org/updates/FEDORA-2022-f90519fad7
because the problem you face is unrelated to the updated bits, please?

Comment 4 Ben Cotton 2022-11-29 17:37:42 UTC
This message is a reminder that Fedora Linux 35 is nearing its end of life.
Fedora will stop maintaining and issuing updates for Fedora Linux 35 on 2022-12-13.
It is Fedora's policy to close all bug reports from releases that are no longer
maintained. At that time this bug will be closed as EOL if it remains open with a
'version' of '35'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, change the 'version' 
to a later Fedora Linux version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora Linux 35 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora Linux, you are encouraged to change the 'version' to a later version
prior to this bug being closed.


Note You need to log in before you can comment on or make changes to this bug.