Bug 203888 - File attribute of TLS_LICENSE(in postfix-2.2.10-1.RHEL4.2)
File attribute of TLS_LICENSE(in postfix-2.2.10-1.RHEL4.2)
Status: CLOSED DUPLICATE of bug 195450
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: postfix (Show other bugs)
4.4
All Linux
medium Severity low
: ---
: ---
Assigned To: Thomas Woerner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-24 03:59 EDT by Masaji Takeyama
Modified: 2007-11-16 20:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-01 10:38:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Masaji Takeyama 2006-08-24 03:59:56 EDT
Description of problem:
I updated it from U3 to U4.
As a result, postfix improved the version from postfix-2.1.5 to postfix-2.2.10.
When permission of the file(TLS_LICENS) changed, I receive the message.

Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux 4 Update 4
(postfix-2.2.10-1.RHEL4.2)

How reproducible:
Always

Steps to Reproduce:
1. up2date -u(up2date -u postfix)
2. rpm -V postfix
3.
  
Actual results:
 # rpm -V postfix
 .M......    /etc/postfix/TLS_LICENSE


Expected results:


Additional info:
It is a result of doing check as for the rpm package. 
 # ls -l /etc/postfix/TLS_LICENSE
 -rw-r--r--  1 root root 1629 May 10 21:20 /etc/postfix/TLS_LICENSE

 # cd /tmp;
 # rpm2cpio  postfix-2.2.10-1.RHEL4.2.i386.rpm | cpio -id;
 # ls -l etc/postfix/TLS_LICENSE;
 -rwxr-xr-x  1 root root 1629 Aug 24 15:57 etc/postfix/TLS_LICENSE

I think that a correct spec file becomes the following. 
 # diff postfix.spec  postfix.spec.org
 454,455c454
 < ##%attr(0755, root, root) %{postfix_config_dir}/TLS_LICENSE
 < %attr(0644, root, root) %{postfix_config_dir}/TLS_LICENSE
 ---
 > %attr(0755, root, root) %{postfix_config_dir}/TLS_LICENSE
Comment 1 Thomas Woerner 2006-09-01 10:38:30 EDT

*** This bug has been marked as a duplicate of 195450 ***

Note You need to log in before you can comment on or make changes to this bug.