Bug 2038921 - PyQt4: FTBFS in Fedora Rawhide
Summary: PyQt4: FTBFS in Fedora Rawhide
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: PyQt4
Version: 36
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Antonio T. (sagitter)
QA Contact: Fedora Extras Quality Assurance
URL: https://koschei.fedoraproject.org/pac...
Whiteboard:
Depends On:
Blocks: F36FTBFS PYTHON3.11 F37FTBFS, RAWHIDEFTBFS
TreeView+ depends on / blocked
 
Reported: 2022-01-10 14:47 UTC by Tomáš Hrnčiar
Modified: 2022-06-27 14:50 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-05-03 10:42:03 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2022-01-10 14:47:20 UTC
Description of problem:
Package PyQt4 fails to build from source in Fedora Rawhide.

Version-Release number of selected component (if applicable):
4.12.3-17.fc35

Steps to Reproduce:
koji build --scratch f36 PyQt4-4.12.3-17.fc35.src.rpm

Additional info:
This package is tracked by Koschei. See:
https://koschei.fedoraproject.org/package/PyQt4

Comment 1 Rex Dieter 2022-01-10 16:17:49 UTC
Nothing (significant) really depends on this in the distro anymore, probably time to retire it.

I'll get the ball rolling this week.

Comment 2 Rex Dieter 2022-01-10 16:32:25 UTC
I suppose I'll orphan instead in case there's anyone interested in performing superheroic measures to fix this.

Comment 3 Ben Cotton 2022-02-08 21:13:26 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 36 development cycle.
Changing version to 36.

Comment 4 Tomáš Hrnčiar 2022-04-21 14:14:35 UTC
Dear Maintainer,

your package has an open Fails To Build From Source bug for Fedora 37.
Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. If you have already fixed this issue, please close this Bugzilla report.

Following the policy for such packages [2], your package will be orphaned if
this bug remains in NEW state more than 8 weeks (not sooner than 2022-03-07).

A week before the mass branching of Fedora 38 according to the schedule [3],
any packages not successfully rebuilt at least on Fedora 36 will be
retired regardless of the status of this bug.

[1] https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedorapeople.org/groups/schedule/f-38/f-38-key-tasks.html

Comment 5 Than Ngo 2022-05-03 10:42:03 UTC
it is fixed in PyQt4-4.12.3-20.fc37, https://koji.fedoraproject.org/koji/taskinfo?taskID=86577944

Comment 6 "FeRD" (Frank Dana) 2022-06-22 09:13:11 UTC
(In reply to Than Ngo from comment #5)
> it is fixed in PyQt4-4.12.3-20.fc37,
> https://koji.fedoraproject.org/koji/taskinfo?taskID=86577944

Apologies for butting in, and I suppose it's really none of my business so I'm fine with not getting an answer to this, but if you're willing to indulge me... I'm just curious:

...Why?

Is it just a case of fixing something for the sake of it being fixed, or are there really still packages — or users — out there depending on PyQt4? It strains credulity, to me, that any code still using PyQt4 would **itself** be compatible with Python 3.11, considering it most likely originated in the early days of Python 2.

It also seems like PyQt4 is probably one of the main reasons (or at least *A* reason) why Qt4 ITSELF is still haunting Fedora. It'd be a shame if PyQt4 is being kept on life support (and therefore adding to the workload of dependency maintainers, who have to do the same for their packages) without some _actual_ — rather than merely presumed, or potential — need.

Sometimes retirement is really the best option, for especially ancient packages. IMHO.

Comment 7 Miro Hrončok 2022-06-22 09:27:04 UTC
$ repoquery --repo=rawhide{,-source} --whatrequires PyQt4-qsci-api  --whatrequires python3-PyQt4  --whatrequires python3-PyQt4-devel  --whatrequires python3-PyQt4-webkit | grep -v PyQt4
gr-air-modes-0:0-0.93.20200807git9e2515a5.fc37.src
ibus-bogo-0:0.4-27.fc36.noarch
ibus-bogo-0:0.4-27.fc36.src
pymol-0:2.5.0-3.fc37.x86_64
python-qdarkstyle-0:3.0.2-4.fc37.src
python3-cclib-0:1.7-4.fc36.noarch
python3-iep-0:3.7-22.fc36.noarch
python3-pyudev-qt4-0:0.23.2-1.fc37.noarch
qhexedit2-0:0.8.9-7.fc36.src

Comment 8 "FeRD" (Frank Dana) 2022-06-26 18:43:57 UTC
Thanks!

(In reply to Miro Hrončok from comment #7)

> gr-air-modes-0:0-0.93.20200807git9e2515a5.fc37.src

A package which requires PyQt4 only for an optional GUI tool, which it will happily build and install without if PyQt4 is not detected. Mostly dependent on Qwt5, which is also packaged for PyQt5.

> ibus-bogo-0:0.4-27.fc36.noarch
> ibus-bogo-0:0.4-27.fc36.src

A project on which development was suspended in 2014, and never resumed. Last commit was in 2017. Last issue opened in repo was 2019.

> pymol-0:2.5.0-3.fc37.x86_64

A package which also supports both PyQt5 and PySide2 (Qt for Python). Plus a fallback Tk interface. PyQt4 seems to be an outdated legacy 'Requires:'.

> python-qdarkstyle-0:3.0.2-4.fc37.src

A style library which is a dependency of other packages based on PyQt5, like python3-spyder and electron-cash. Clearly not actually PyQt4-specific.

> python3-cclib-0:1.7-4.fc36.noarch

A library with a PyQt4 dependency only for a throwaway progress-dialog widget that hasn't been updated in four years. The corresponding text-based progress display has received commits within the past 3 months. PyQt4 dialog could be trivially ported to PyQt5 / PyQt6 in an afternoon, if anyone were interested in it, but it doesn't seem they are.

> python3-iep-0:3.7-22.fc36.noarch

A package which hasn't been updated since 2016, has a missing project website, and does not appear to be available at pypi.org.

> python3-pyudev-qt4-0:0.23.2-1.fc37.noarch

A library binding that provides both PyQt4 and PyQt5 widgets. PyQt4 version could be dropped without removing the PyQt5 version. PyQt4 subpackage has no dependents.

> qhexedit2-0:0.8.9-7.fc36.src

A widget that also has a PyQt5 version. PyQt4 version could be dropped without removing the PyQt5 version. Entire package (including PyQt5 version) has no dependents of any kind.

Comment 9 Rex Dieter 2022-06-27 14:50:31 UTC
Looks like someone else (besides me) is primary PyQt4 maintainer now (they must've picked it up after I orphaned it? don't recall)


Note You need to log in before you can comment on or make changes to this bug.