Bug 203923 - HTTP byte range support is not complete
Summary: HTTP byte range support is not complete
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Backend   
(Show other bugs)
Version: rhn410
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bryan Kearney
QA Contact: Beth Nackashi
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 189170
TreeView+ depends on / blocked
 
Reported: 2006-08-24 15:10 UTC by James Bowes
Modified: 2013-01-10 09:50 UTC (History)
2 users (show)

Fixed In Version: RHN415
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-09 20:36:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description James Bowes 2006-08-24 15:10:14 UTC
Yum required RHN to support http requests for byte ranges. We implemented this,
but not for the full spec. As a result, someone, somewhere is requesting byte
ranges in a way we do not support. Before, we would have returned The entire
file. Now, we error.

We need support for the full spec.

Comment 1 Bret McMillan 2006-08-30 14:04:55 UTC
Moving to rhn415-must.

Comment 2 James Bowes 2006-09-08 18:40:22 UTC
A fix exists in 415 now.

Comment 3 James Bowes 2006-10-18 17:34:35 UTC
For testing, I would suggest making sure that there are no regressions around
up2date and yum downloading rpms from RHN, ie make sure 'yum install zsh' and
'up2date zsh' work correctly.

Testing the added behaviour is a little trickier, since we have no client code
that does this. I did pretty extensive unit testing on the byte range module,
however. Unit tests live in RELEASE-4.1/backend/server/byterangetests.py

Comment 4 Beth Nackashi 2006-10-18 21:32:17 UTC
Well, this seems to look ok on webqa for yum and up2date.  Not that I fully
understood what the original issue was, exactly, or anything.

Comment 5 Beth Nackashi 2006-10-26 18:07:16 UTC
moving from VERIFIED to RELEASE_PENDING since stage push is complete

Comment 6 Brandon Perkins 2006-11-09 20:36:03 UTC
closing -- current release.  RHN415 is now in production.


Note You need to log in before you can comment on or make changes to this bug.