Bug 203954 - Unable to reset PIN
Unable to reset PIN
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: esc (Show other bugs)
5.0
All Linux
high Severity medium
: ---
: ---
Assigned To: Jack Magne
:
: 206992 (view as bug list)
Depends On:
Blocks: 181509
  Show dependency treegraph
 
Reported: 2006-08-24 13:48 EDT by Zack Cerza
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-13 08:13:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zack Cerza 2006-08-24 13:48:36 EDT
Description of problem:
esc is not allowing me to reset my smartcard's PIN

Version-Release number of selected component (if applicable):
esc-1.0.0-7.fc6

How reproducible:
Always

Steps to Reproduce:
1. Insert smartcard
2. In esc, press 'Reset Pin' (that should be PIN, btw)
3. Enter new "key password" twice as requested (wait, what about the PIN?)
4. Press OK (pressing Enter should work also but doesn't)
5. Enter LDAP Authentication as requested
6. Press Submit (pressing Enter should work also but doesn't)
  
Actual results:
Error dialog titled 'Alert' saying: 
"PIN Reset for key xxxx-xxxx-xxxx-xxxx-xxxx failed. Error 4
Server Response:Problem resetting token's pin" (this error message obviously has
a few punctuation/spacing/capitalization problems)

Expected results:
The PIN is reset.

Additional info:
Comment 2 Orla Hegarty 2006-09-14 18:26:10 EDT
All of these bugs are being marked as targeted to be fixed in beta 2. However
only a subset of these bugs will be actual beta blockers. I am marking all of
these bugs a beta 2 target milestones.

Beta Blockers reflect bugs that are critical to this beta 2 release. Flags will
be set as appropriate on a case by case basis for each critical beta blocker. 
Comment 3 Chandrasekar Kannan 2006-09-18 18:42:44 EDT
*** Bug 206992 has been marked as a duplicate of this bug. ***
Comment 4 Jack Magne 2006-09-19 12:36:47 EDT
Issue addressed in Rawhide build esc-1.0.0-12 when available. PIN Reset should
work correctly now.
Comment 5 Orla Hegarty 2006-09-19 20:12:28 EDT
Release Criteria matches 16.c
Comment 8 Jay Turner 2006-11-13 08:13:44 EST
Closing out as resolved with the 20061111.0 trees.

Note You need to log in before you can comment on or make changes to this bug.