Bug 2039566 (CVE-2022-22738) - CVE-2022-22738 Mozilla: Heap-buffer-overflow in blendGaussianBlur
Summary: CVE-2022-22738 Mozilla: Heap-buffer-overflow in blendGaussianBlur
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2022-22738
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2037104 2037105 2037106 2037107 2037108 2037109 2037110 2037111 2037149 2037150 2037151 2037152 2037153 2037154 2037155 2037156
Blocks: 2037102
TreeView+ depends on / blocked
 
Reported: 2022-01-12 00:13 UTC by Doran Moppert
Modified: 2022-01-12 14:30 UTC (History)
5 users (show)

Fixed In Version: firefox 91.5, thunderbird 91.5
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-01-12 14:30:27 UTC


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2022:0123 0 None None None 2022-01-12 10:23:02 UTC
Red Hat Product Errata RHSA-2022:0124 0 None None None 2022-01-12 12:27:53 UTC
Red Hat Product Errata RHSA-2022:0125 0 None None None 2022-01-12 11:46:02 UTC
Red Hat Product Errata RHSA-2022:0126 0 None None None 2022-01-12 12:00:08 UTC
Red Hat Product Errata RHSA-2022:0127 0 None None None 2022-01-12 13:04:09 UTC
Red Hat Product Errata RHSA-2022:0128 0 None None None 2022-01-12 12:16:25 UTC
Red Hat Product Errata RHSA-2022:0129 0 None None None 2022-01-12 12:23:36 UTC
Red Hat Product Errata RHSA-2022:0130 0 None None None 2022-01-12 11:55:12 UTC
Red Hat Product Errata RHSA-2022:0131 0 None None None 2022-01-12 12:02:12 UTC
Red Hat Product Errata RHSA-2022:0132 0 None None None 2022-01-12 12:05:50 UTC

Description Doran Moppert 2022-01-12 00:13:18 UTC
Applying a CSS filter effect could have accessed out of bounds memory. This could have lead to a heap-buffer-overflow causing a potentially exploitable crash.



External Reference:

https://www.mozilla.org/en-US/security/advisories/mfsa2022-02/#CVE-2022-22738

Comment 1 errata-xmlrpc 2022-01-12 10:22:59 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8.2 Extended Update Support

Via RHSA-2022:0123 https://access.redhat.com/errata/RHSA-2022:0123

Comment 2 errata-xmlrpc 2022-01-12 11:46:00 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8.1 Update Services for SAP Solutions

Via RHSA-2022:0125 https://access.redhat.com/errata/RHSA-2022:0125

Comment 3 errata-xmlrpc 2022-01-12 11:55:10 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8

Via RHSA-2022:0130 https://access.redhat.com/errata/RHSA-2022:0130

Comment 4 errata-xmlrpc 2022-01-12 12:00:06 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8.4 Extended Update Support

Via RHSA-2022:0126 https://access.redhat.com/errata/RHSA-2022:0126

Comment 5 errata-xmlrpc 2022-01-12 12:02:10 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8.1 Update Services for SAP Solutions

Via RHSA-2022:0131 https://access.redhat.com/errata/RHSA-2022:0131

Comment 6 errata-xmlrpc 2022-01-12 12:05:48 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8.2 Extended Update Support

Via RHSA-2022:0132 https://access.redhat.com/errata/RHSA-2022:0132

Comment 7 errata-xmlrpc 2022-01-12 12:16:22 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8.4 Extended Update Support

Via RHSA-2022:0128 https://access.redhat.com/errata/RHSA-2022:0128

Comment 8 errata-xmlrpc 2022-01-12 12:23:33 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8

Via RHSA-2022:0129 https://access.redhat.com/errata/RHSA-2022:0129

Comment 9 errata-xmlrpc 2022-01-12 12:27:51 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 7

Via RHSA-2022:0124 https://access.redhat.com/errata/RHSA-2022:0124

Comment 10 errata-xmlrpc 2022-01-12 13:04:07 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 7

Via RHSA-2022:0127 https://access.redhat.com/errata/RHSA-2022:0127

Comment 11 Product Security DevOps Team 2022-01-12 14:30:25 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2022-22738


Note You need to log in before you can comment on or make changes to this bug.