Bug 20397 - Enhancement to netatalk.spec file and a Makefile
Enhancement to netatalk.spec file and a Makefile
Status: CLOSED NOTABUG
Product: Red Hat Powertools
Classification: Retired
Component: netatalk (Show other bugs)
7.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-05 17:01 EST by David D. Kilzer
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-06 12:41:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David D. Kilzer 2000-11-05 17:01:35 EST
Here is a better fix for the bad symlinks bug described in this changelog
entry:

> * Wed Aug 2 2000 Tim Powers <timp@redhat.com>
> - fix symlinks not being relative.

Here's a patch for the netatalk.spec file itself:

diff -u netatalk.spec.orig netatalk.spec
--- netatalk.spec.orig	Mon Aug  7 07:01:34 2000
+++ netatalk.spec	Sun Nov  5 12:47:59 2000
@@ -68,13 +68,6 @@
 mkdir -p $RPM_BUILD_ROOT/usr/lib/atalk
 make install INSTALL_PREFIX=$RPM_BUILD_ROOT
MANDIR=$RPM_BUILD_ROOT%{_mandir}
 
-(
-  cd $RPM_BUILD_ROOT/usr/lib/atalk/filters/
-  for i in * ; do
-    ln -sf ../../../sbin/psf $i
-  done
-)
-
 install -m644 config/AppleVolumes.default
$RPM_BUILD_ROOT/etc/atalk/AppleVolumes.default
 install -m644 config/afpd.conf $RPM_BUILD_ROOT/etc/atalk/afpd.conf
 install -m644 config/atalkd.conf $RPM_BUILD_ROOT/etc/atalk/atalkd.conf


Here is a new netatalk-asun.install.patch patch with the fix to
etc/psf/Makefile
included (note that only the first diff changed):


diff -u netatalk-1.4b2+asun2.1.3.orig/etc/psf/Makefile
netatalk-1.4b2+asun2.1.3/etc/psf/Makefile
--- netatalk-1.4b2+asun2.1.3.orig/etc/psf/Makefile	Thu Feb  4 00:57:52 1999
+++ netatalk-1.4b2+asun2.1.3/etc/psf/Makefile	Sun Nov  5 12:29:17 2000
@@ -14,7 +14,14 @@
 	ofmpap ifmpap tfmpap ifmpaprev tfmpaprev \
 	ofwmpap ifwmpap tfwmpap ifwmpaprev tfwmpaprev
 
-all : ${TARGETS}
+all : ${TARGETS} ${LINKS}
+
+${LINKS} :
+	if [ x"${INSTALL_PREFIX}" != x ]; then \
+	    ln -sf `echo ${SBINDIR} | sed -e s@^${INSTALL_PREFIX}@@`/psf $@; \
+	else \
+	    ln -sf ${SBINDIR}/psf $@; \
+	fi
 
 psf : psf.o
 	${CC} ${CFLAGS} -o psf psf.o ${LIBDIRS} ${LIBS}
@@ -39,7 +46,7 @@
 	${INSTALL} -c psf ${SBINDIR}
 	for i in ${LINKS} ; do \
 	    rm -f ${RESDIR}/filters/$$i; \
-	    ln -s ${SBINDIR}/psf ${RESDIR}/filters/$$i; \
+	    cp -a $$i ${RESDIR}/filters/$$i; \
 	done
 
 clean :
diff -uNr netatalk-1.4b2+asun2.1.3.orig/man/man8/Makefile
netatalk-1.4b2+asun2.1.3/man/man8/Makefile
--- netatalk-1.4b2+asun2.1.3.orig/man/man8/Makefile	Wed May 21 02:35:43
1997
+++ netatalk-1.4b2+asun2.1.3/man/man8/Makefile	Sat Mar 20 15:09:20 1999
@@ -9,19 +9,25 @@
 LINKS=
 
 all :
-
-install : all
-	-mkdir ${MANDIR}/man8
 	for i in ${SRC} ; do \
-	    rm -f ${MANDIR}/man8/$$i; \
 	    sed -e s@:DESTDIR:@${DESTDIR}@ -e s@:SBINDIR:@${SBINDIR}@ \
 		-e s@:BINDIR:@${BINDIR}@ -e s@:RESDIR:@${RESDIR}@ \
 		-e s@:ETCDIR:@${ETCDIR}@ -e s@:LIBDIR:@${LIBDIR}@ \
 		-e s@:INCDIR:@${INCDIR}@ \
-		< $$i > ${MANDIR}/man8/$$i; \
+		< $$i > $$i.tmp; \
+	done
+
+install : 
+	-mkdir ${MANDIR}/man8
+	for i in ${SRC} ; do \
+	    rm -f ${MANDIR}/man8/$$i; \
+	    install -m644 $$i.tmp ${MANDIR}/man8/$$i; \
 	done
 
 clean :
+	for i in ${SRC}; do \
+	    rm -f $$i.tmp; \
+	done
 
 tags : ${SRC}
 
diff -uNr netatalk-1.4b2+asun2.1.3.orig/sys/linux/Makefile
netatalk-1.4b2+asun2.1.3/sys/linux/Makefile
--- netatalk-1.4b2+asun2.1.3.orig/sys/linux/Makefile	Sun Feb 28 06:10:59
1999
+++ netatalk-1.4b2+asun2.1.3/sys/linux/Makefile	Sat Mar 20 15:09:20 1999
@@ -66,8 +66,7 @@
 	fi \
 	fi
 
-install : ${ETCDIR} install-sysv install-bsd
-	-mkdir ${DESTDIR} ${SBINDIR} ${BINDIR} ${LIBDIR}
+install : 
 	for i in ${ALL}; \
 	    do (cd $$i; ${MAKE} ${MFLAGS} CC="${CC}" \
 		ADDLIBS="${ADDLIBS}" DEFS="${DEFS}" OPTOPTS="${OPTOPTS}" \
@@ -76,10 +75,6 @@
 		AFSDIR="${AFSDIR}" KRBDIR="${KRBDIR}" AFPLIBS="${AFPLIBS}" \
 		INSTALL="${INSTALL}" $@); \
 	done
-	if [ -d /etc/pam.d -a ! -f /etc/pam.d/netatalk ]; then \
-	   	${INSTALL} ../../config/netatalk.pamd /etc/pam.d/netatalk; \
-		echo "PAM netatalk file installed."; \
-	fi 
 	@echo
 	@echo "Install is done.  Don't forget to add lines from"
 	@echo "services.atalk to /etc/services."
Comment 1 Ngo Than 2000-11-10 19:45:19 EST
don't need this patch, since i updated it to1.5pre2.

Note You need to log in before you can comment on or make changes to this bug.