Bug 20398 - tar stops archiving files at 40960000 bytes (40Mb)
tar stops archiving files at 40960000 bytes (40Mb)
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: tar (Show other bugs)
6.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-05 18:02 EST by Ricky Ng-Adam
Modified: 2007-04-18 12:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-07 08:45:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ricky Ng-Adam 2000-11-05 18:02:35 EST
tar stops archiving files at 40960000 bytes (40Mb)

[root@sonia /backup]# tar cvflp sonia05112000.tgz /usr/local/SONIA/*
tar: Removing leading `/' from member names

[...]

File size limit exceeded

[root@sonia /backup]# ls -al
-rw-r--r--    1 root     root     40960000 Nov  5 17:29 sonia05112000.tgz

[root@sonia /backup]# uname -a
Linux sonia.etsmtl.ca 2.2.14-5.0 #1 Tue Mar 7 21:07:39 EST 2000 i686 
unknown

[root@sonia log]# cat /var/log/dmesg
Linux version 2.2.14-5.0 (root@porky.devel.redhat.com) (gcc version 
egcs-2.91.66
 19990314/Linux (egcs-1.1.2 release)) #1 Tue Mar 7 21:07:39 EST 2000
relocating initrd image:
    initrd_start:0xc0f96000    initrd_end:0xc0ffff74
    mem_start:0xc026c000    mem_end:0xc7ff0000
    initrd_size:0x00069f74     dest:0xc7f86000
Detected 300689602 Hz processor.
Console: colour VGA+ 80x25
Calibrating delay loop... 299.83 BogoMIPS
Memory: 127432k/131008k available (1060k kernel code, 412k reserved, 1616k 
data,
 64k init, 0k bigmem)
Dentry hash table entries: 262144 (order 9, 2048k)
Buffer cache hash table entries: 131072 (order 7, 512k)
Page cache hash table entries: 32768 (order 5, 128k)
VFS: Diskquotas version dquot_6.4.0 initialized
CPU: Intel Pentium II (Deschutes) stepping 02
Enabling extended fast FPU save and restore...done.
Checking 386/387 coupling... OK, FPU using exception 16 error reporting.
Checking 'hlt' instruction... OK.
POSIX conformance testing by UNIFIX
mtrr: v1.35a (19990819) Richard Gooch (rgooch@atnf.csiro.au)
PCI: PCI BIOS revision 2.10 entry at 0xf0750
PCI: Using configuration type 1
PCI: Probing PCI hardware
Linux NET4.0 for Linux 2.2
Based upon Swansea University Computer Society NET3.039
NET4: Unix domain sockets 1.0 for Linux NET4.0.
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IGMP
TCP: Hash tables configured (ehash 131072 bhash 65536)
Initializing RT netlink socket
Starting kswapd v 1.5
Detected PS/2 Mouse Port.
Serial driver version 4.27 with MANY_PORTS MULTIPORT SHARE_IRQ enabled
ttyS00 at 0x03f8 (irq = 4) is a 16550A
ttyS01 at 0x02f8 (irq = 3) is a 16550A
pty: 256 Unix98 ptys configured
apm: BIOS version 1.2 Flags 0x03 (Driver version 1.9)
Real Time Clock Driver v1.09
RAM disk driver initialized:  16 RAM disks of 4096K size
PIIX4: IDE controller on PCI bus 00 dev 21
PIIX4: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0xb800-0xb807, BIOS settings: hda:pio, hdb:pio
    ide1: BM-DMA at 0xb808-0xb80f, BIOS settings: hdc:pio, hdd:pio
keyboard: Too many NACKs -- noisy kbd cable?
keyboard: Too many NACKs -- noisy kbd cable?
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
md driver 0.90.0 MAX_MD_DEVS=256, MAX_REAL=12
raid5: measuring checksumming speed
raid5: MMX detected, trying high-speed MMX checksum routines
   pII_mmx   :   698.754 MB/sec
   p5_mmx    :   741.807 MB/sec
   8regs     :   517.017 MB/sec
   32regs    :   294.513 MB/sec
using fastest function: p5_mmx (741.807 MB/sec)
scsi : 0hosts.
scsi : detected total.
md.c: sizeof(mdp_super_t) = 4096
Partition check:
RAMDISK: Compressed image found at block 0
autodetecting RAID arrays
autorun ...
... autorun DONE.
VFS: Mounted root (ext2 filesystem).
(scsi0) <Adaptec AIC-7890/1 Ultra2 SCSI host adapter> found at PCI 0/6/0
(scsi0) Wide Channel, SCSI ID=7, 32/255 SCBs
(scsi0) Downloading sequencer code... 396 instructions downloaded
enable_irq() unbalanced from c801b3c7
scsi0 : Adaptec AHA274x/284x/294x (EISA/VLB/PCI-Fast SCSI) 5.1.28/3.2.4
       <Adaptec AIC-7890/1 Ultra2 SCSI host adapter>
scsi : 1 host.
(scsi0:0:6:0) Synchronous at 10.0 Mbyte/sec, offset 15.
  Vendor: SEAGATE   Model: ST410800N         Rev: 0025
  Type:   Direct-Access                      ANSI SCSI revision: 02
Detected scsi disk sda at scsi0, channel 0, id 6, lun 0
SCSI device sda: hdwr sector= 512 bytes. Sectors= 17755614 [8669 MB] [8.7 
GB]
 sda: sda1 sda2 < sda5 sda6 sda7 sda8 sda9 sda10 sda11 >
autodetecting RAID arrays
autorun ...
... autorun DONE.
VFS: Mounted root (ext2 filesystem) readonly.
change_root: old root has d_count=1
Trying to unmount old root ... okay
Freeing unused kernel memory: 64k freed
Adding Swap: 144544k swap-space (priority -1)

[root@sonia redhat]# rpm -qf /bin/tar
tar-1.13.17-3

[root@sonia redhat]# rpm -qa | grep glibc
glibc-devel-2.1.3-21
glibc-2.1.3-21
Comment 1 Ricky Ng-Adam 2000-11-07 08:45:06 EST
Tried reinstalling tar and glibc (from 6.2) without success:

[root@sonia log]# rpm -qa | grep glibc
glibc-profile-2.1.3-15
glibc-devel-2.1.3-15
glibc-2.1.3-15

Comment 2 Bernhard Rosenkraenzer 2000-11-08 03:17:25 EST
I can't reproduce this - I guess it's a misconfiguration on your side (check your ulimits and quota, for example).
Comment 3 Daniel Roesen 2000-11-08 06:19:56 EST
isn't WORKSFORME the correct "Resolution"? That you can't reproduce it doesn't 
mean that it's not a bug :]
Comment 4 Ricky Ng-Adam 2000-11-08 14:40:53 EST
Ok, you can stop fighting now ;-).  The issue can stay at resolved as it was in 
fact a ulimit problem (probably set by Bastille but I have no idea why...):

[root@sonia /etc]# ulimit -a
core file size (blocks)  1000000
data seg size (kbytes)   unlimited
file size (blocks)       40000
max memory size (kbytes) unlimited
stack size (kbytes)      8192
cpu time (seconds)       unlimited
max user processes       100
pipe size (512 bytes)    8
open files               1024
virtual memory (kbytes)  2105343

Thanks and sorry for the bother!
Comment 5 Daniel Roesen 2000-11-08 15:23:58 EST
Hehe, good catch, Bero :-]

Note You need to log in before you can comment on or make changes to this bug.