Bug 203993 - change openmotif to be parallel installable with lesstif
change openmotif to be parallel installable with lesstif
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openmotif (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
:
Depends On:
Blocks: 203274
  Show dependency treegraph
 
Reported: 2006-08-24 17:21 EDT by Patrice Dumas
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-31 04:30:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrice Dumas 2006-08-24 17:21:13 EDT
Description of problem:

This is not really a bug report, but a place for the coordination
around openmotif/lesstif packaging to have parallel installable 
packages to ease migration and also to help those who prefer one or
the other implementation to chose. All that is following the switch
to lesstif in fedora to cope with openmotif not having an OSI 
compatible licence (and even this issue set apart this would be a good
thing to be able to choose one).

lesstif package is proposed in Bug #203274.

the -devel packages will conflict. There could be a virtual provide,
like motif-devel describing the motif API provided by the -devel 
package, which would be, for lesstif at version 2.1, and for 
openmotif at 2.3.

the package containing the libraries shouldn't conflict. Currently
the openmotif and lesstif libs have different sonames and different 
names, so the library names are not an issue. 

What could conflict is mwm, which is in lesstif-mwm in the proposed
lesstif package. There is also uil, it is proposed to be in 
lesstif-devel. And xmbind could also conflict, and is more 
worrisome to me since it should logically be in the main package, 
with the libraries.

To avoid the xmbind conflict there are 2 possible solutions: 
* move xmbind to a separate package
* rename programs, scripts and man pages that could conflict
  in such a way that they don't conflict (like openmotif-xmbind
  or lesstif-xmbind).

Are you ready to split openmotif according to a scheme 
compatible with what I propose above to avoid conflicts?
What would seem better for you to avoid the xmbind conflict? 


As a side note, lesstif and openmotif provide libraries
which may have the same soname and name but be ABI incompatible.
So even if the packages may be parallel installable it would
be safer for packaes built against one or the other to 
require the right one and not rely on the soname found 
automatically by rpm. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Patrice Dumas 2006-08-31 02:57:04 EDT
In the end I split a lesstif-clients with uil and xmbind
out of lesstif. 

So there is 
lesstif
lesstif-devel
lesstif-clients uil and xmbind
lesstif-mwm
Comment 2 Rex Dieter 2006-08-31 09:43:05 EDT
Thomas, please be so kind as to justify your closing (without any comment) of
this bug/enhancement-request as NOTABUG.
Comment 3 Thomas Woerner 2006-08-31 10:41:30 EDT
Rex, as you know, there will be no OpenMotif package anymore. Therefore there is
absolutely no need to change anything in this package.

No package, no bug.
Comment 4 Patrice Dumas 2006-08-31 10:54:07 EDT
I am still hoping that openmotif will still be there for FC6
such that there is more than 1 month for transition and testing.

Moreover it would have been nice to leave an openmotif package
that play as nice as possible with lesstif given that it is
more than likely that some users will need openmotif for 
longer time.
Comment 5 Rex Dieter 2006-08-31 10:57:05 EDT
> I am still hoping that openmotif will still be there for FC6

To quote Wayne's World: "live in the now".  Aint gonna happen (unless openmotif
miraculously changes their licensing *soon*).
Comment 6 Patrice Dumas 2006-08-31 11:19:06 EDT
That's not very nice for Motif library users. Doing
such a change without notice and no transition release 
to have time to adapt, although it is well known that 
lesstif has issues openmotif don't have is not very
carefull.
Comment 7 Rex Dieter 2006-08-31 11:26:45 EDT
> That's not very nice for Motif library users.

Please take further discussion to the fab list.  bugzilla is not the appropriate
forum.  For background, see:
http://fedoraproject.org/wiki/RexDieter/openmotif


Note You need to log in before you can comment on or make changes to this bug.