Bug 204007 - install exception, missing /usr/share/zoneinfo/zone.tab, on rawhide-20060825
Summary: install exception, missing /usr/share/zoneinfo/zone.tab, on rawhide-20060825
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: rawhide
Hardware: ia64 Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: fedora-ia64
TreeView+ depends on / blocked
 
Reported: 2006-08-24 22:51 UTC by Aron Griffis
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-25 15:41:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (17.20 KB, text/plain)
2006-08-24 22:51 UTC, Aron Griffis
no flags Details
anacdump.txt (53.32 KB, text/plain)
2006-08-24 23:01 UTC, Aron Griffis
no flags Details

Description Aron Griffis 2006-08-24 22:51:28 UTC
Created attachment 134867 [details]
anaconda.log

Comment 1 Aron Griffis 2006-08-24 22:51:28 UTC
Description of problem:
Anaconda exception during rx1600 installation via PXE with kernel cmdline:
vnc vncpassword=qwerty askmethod
Method chosen is http, interface configured with DHCP

Version-Release number of selected component (if applicable):
Linux version 2.6.17-1.2583.fc6 (brewbuilder@ia64-1.build.redhat.com) (gcc
version 4.1.1 20060817 (Red Hat 4.1.1-18)) #1 SMP Tue Aug 22 00:30:06 EDT 2006
Anaconda is from rawhide-20060825, I don't know the version

Comment 2 Aron Griffis 2006-08-24 23:01:23 UTC
Created attachment 134868 [details]
anacdump.txt

Comment 3 Aron Griffis 2006-08-24 23:03:16 UTC
Here's the python traceback:

Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 920, in nextClicked
    self.setScreen ()
  File "/usr/lib/anaconda/gui.py", line 1005, in setScreen
    self.currentWindow = newScreenClass(ics)
  File "/usr/lib/anaconda/iw/timezone_gui.py", line 48, in __init__
    self.zonetab = zonetab.ZoneTab()
  File "/usr/share/system-config-date/zonetab.py", line 31, in __init__
    self.readZoneTab (fn)
  File "/usr/share/system-config-date/zonetab.py", line 74, in readZoneTab
    f = open (fn, 'r')
IOError: [Errno 2] No such file or directory: '/usr/share/zoneinfo/zone.tab'


Comment 4 Aron Griffis 2006-08-24 23:10:34 UTC
This looks pretty screwy:

sh-3.1# ls -l /usr/share/zoneinfo
total 1
?--------- ? ?    ?    ?            ? /usr/share/zoneinfo/zone.tab
drwxr-xr-x 2 root 0  661 Aug 24  2006 Africa
drwxr-xr-x 6 root 0 1848 Aug 24  2006 America
drwxr-xr-x 2 root 0  133 Aug 24  2006 Antarctica
drwxr-xr-x 2 root 0   29 Aug 24  2006 Arctic
drwxr-xr-x 2 root 0 1079 Aug 24  2006 Asia
drwxr-xr-x 2 root 0  156 Aug 24  2006 Atlantic
drwxr-xr-x 2 root 0  271 Aug 24  2006 Australia
drwxr-xr-x 2 root 0  167 Aug 24  2006 Canada
drwxr-xr-x 2 root 0  707 Aug 24  2006 Europe
drwxr-xr-x 2 root 0  149 Aug 24  2006 Indian
-r--r--r-- 2 root 0  125 Aug 22  2006 Japan
drwxr-xr-x 2 root 0   51 Aug 24  2006 Mideast
drwxr-xr-x 2 root 0  492 Aug 24  2006 Pacific
drwxr-xr-x 2 root 0  221 Aug 24  2006 US


Comment 5 Prarit Bhargava 2006-08-25 15:41:27 UTC
Seems to be fixed in latest 20060825 rawhide.


Note You need to log in before you can comment on or make changes to this bug.