Bug 2040189 - Firefox 96.0 hangs after a while - loses connectivity
Summary: Firefox 96.0 hangs after a while - loses connectivity
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 35
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-01-13 08:43 UTC by Alexander Ploumistos
Modified: 2022-01-13 11:36 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-01-13 11:36:46 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Mozilla Foundation 1749910 0 P1 RESOLVED [2022-01-13] Hangs in socket thread 2022-01-13 11:36:46 UTC

Description Alexander Ploumistos 2022-01-13 08:43:43 UTC
Last night I installed firefox-96.0-1.fc35 and I noticed that after a while it would not load any remote content either in new tabs or by reloading open ones. Websites that report on connectivity (e.g. gmail) display messages about having lost the connection. When this happens, I also get a GeckoMain process that seems stuck at 100-120% CPU and which has to be manually terminated after closing firefox. If I start firefox from a terminal, I get multiple repetitions of this message when the bug manifests itself:

###!!! [Parent][RunMessage] Error: Channel closing: too late to send/recv, messages will be lost

Comment 2 Alexander Ploumistos 2022-01-13 11:36:46 UTC
Closing this as NOTABUG, the actual issue was presumably caused by one of Mozilla's network service providers.
Waiting for an official announcement:
https://bugzilla.mozilla.org/show_bug.cgi?id=1749910#c52


Note You need to log in before you can comment on or make changes to this bug.