Bug 2040414 - [RFE:EPEL9] EPEL9 branch for pylint
Summary: [RFE:EPEL9] EPEL9 branch for pylint
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: pylint
Version: epel9
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Orion Poplawski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 2099819 (view as bug list)
Depends On: 2046326
Blocks: 2035373
TreeView+ depends on / blocked
 
Reported: 2022-01-13 16:32 UTC by Pat Riehecky
Modified: 2022-08-24 20:40 UTC (History)
5 users (show)

Fixed In Version: pylint-2.13.7-1.el9
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-08-24 20:40:24 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Pat Riehecky 2022-01-13 16:32:57 UTC
Description of problem:

Can this be branched for EPEL9?

Comment 1 Pat Riehecky 2022-01-28 20:02:14 UTC
Will you be able to branch and build pylint in epel9?

Comment 2 Orion Poplawski 2022-01-29 02:31:29 UTC
There are still missing deps:

DEBUG util.py:444:  No matching package to install: 'python3-astroid >= 2.8.0'
DEBUG util.py:444:  No matching package to install: 'python3-isort'
DEBUG util.py:444:  No matching package to install: 'python3-mccabe'
DEBUG util.py:444:  No matching package to install: 'python3-pytest-runner'

I'm not up for chasing them down myself.

Comment 3 Fedora Update System 2022-08-15 01:50:00 UTC
FEDORA-EPEL-2022-99c1870939 has been submitted as an update to Fedora EPEL 9. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-99c1870939

Comment 4 Orion Poplawski 2022-08-15 01:51:15 UTC
*** Bug 2099819 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2022-08-16 01:44:01 UTC
FEDORA-EPEL-2022-99c1870939 has been pushed to the Fedora EPEL 9 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-99c1870939

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Fedora Update System 2022-08-24 20:40:24 UTC
FEDORA-EPEL-2022-99c1870939 has been pushed to the Fedora EPEL 9 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.