Bug 20405 - System hangs after resuming from hibernation
System hangs after resuming from hibernation
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-06 00:36 EST by Manuel "Chilli" Chakravarty
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-14 22:20:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Manuel "Chilli" Chakravarty 2000-11-06 00:36:27 EST
I am having serious kernel problems with hibernation on a Sharp PC-PJ2-X4
(a Japanese model similar to the Sharp Actius PC-A290 sold outside of
Japan).  I am sure that it is a kernel bug in 7.0, because I didn't have
any problems with RedHat 6.x on the same system.

When resuming the system from hibernation (save-to-disk), the system often
(but not always) either immediately hangs or looses the ability to access
the builtin IDE harddisk (and prints "hda: lost interrupt" to the console).
Usually, this problem appears with a 20-30% chance; however, if I have used
a PCMCIA card (ethernet or SCSI) before hibernation, the problem is
guaranteed to occur.  I have inspected and toyed around with the
configuration under /etc/sysconfig/apmd, but this didn't seem to have any
effect.

The configuration of the machine is as follows:
  CPU: Mobile Pentium II
  Host bridge: Intel 440BX - 82443BX Host (no AGP)
  IDE interface: Intel 82371AB PIIX4 IDE (rev 1)
  hda: TOSHIBA MK1214GAP
  CardBus bridge: Ricoh RL5C475 rev 00 PCI-to-CardBus
  Kernel: 2.2.16-22
It has a Phoenix NoteBIOS.
Comment 1 Paul Kronenwetter 2002-07-11 22:35:51 EDT
I'm observing the same problem with a different machine and kernel.  Ever since
the 2.4.18 series was available from Rawhide I've seen this problem.  Stock (and
all updates to) 7.2 work fine.  Since 7.3 comes with the 2.4.18, it has this
problem.  I'm running a Gateway 9300:

# lspci   
00:00.0 Host bridge: Intel Corp. 82815 815 Chipset Host Bridge and Memory
Controller Hub (rev 11)
00:01.0 PCI bridge: Intel Corp. 82815 815 Chipset AGP Bridge (rev 11)
00:1e.0 PCI bridge: Intel Corp. 82801BAM/CAM PCI Bridge (rev 03)
00:1f.0 ISA bridge: Intel Corp. 82801BAM ISA Bridge (LPC) (rev 03)
00:1f.1 IDE interface: Intel Corp. 82801BAM IDE U100 (rev 03)
00:1f.2 USB Controller: Intel Corp. 82801BA/BAM USB (Hub  (rev 03)
00:1f.3 SMBus: Intel Corp. 82801BA/BAM SMBus (rev 03)
00:1f.4 USB Controller: Intel Corp. 82801BA/BAM USB (Hub  (rev 03)
01:00.0 VGA compatible controller: ATI Technologies Inc Rage Mobility M4 AGP
02:02.0 CardBus bridge: Texas Instruments PCI1420
02:02.1 CardBus bridge: Texas Instruments PCI1420
02:06.0 Communication controller: Lucent Microelectronics F-1156IV WinModem
(V90, 56KFlex) (rev 01)
02:07.0 FireWire (IEEE 1394): Lucent Microelectronics FW323 (rev 04)
02:08.0 Multimedia audio controller: ESS Technology ES1988 Allegro-1 (rev 12)

    ide0: BM-DMA at 0x1800-0x1807, BIOS settings: hda:DMA, hdb:pio
hda: TOSHIBA MK3017GAP, ATA DISK drive

Ideas on this are appreciated.  I'm likely to downgrade to the kernel from 7.2
so I can suspend and resume reliably.

Thanks!
Comment 2 Paul Kronenwetter 2002-07-11 22:44:51 EDT
I may have found a workaround for my laptop.  Looking at Bug#20658 I tried
changing /etc/sysconfig/apmd to stop and restart PCMCIA services on
suspend/resume.  This appears to have changed the behavior.  I have since been
able to suspend/resume twice without the machine hanging on the HD.  I'll need
to try this with a different PCMCIA card (I switch between two) so more later...

Comment 3 Alan Cox 2002-12-14 22:20:53 EST
Thats a BIOS problem not a Linux one so closed. 

Note You need to log in before you can comment on or make changes to this bug.