Bug 204051 - mock stops with no attribute 'transaction' error
mock stops with no attribute 'transaction' error
Status: CLOSED NEXTRELEASE
Product: Fedora Hosted Projects
Classification: Retired
Component: mock (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Clark Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-25 05:42 EDT by Mamoru TASAKA
Modified: 2013-01-09 23:02 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-29 10:10:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mamoru TASAKA 2006-08-25 05:42:11 EDT
Description of problem:
When I try to rebuild some srpm in mock, mock instantly stops
with the following error.

My system is 20060824 rawhide.

Version-Release number of selected component (if applicable):
mock-0.6.2-1.fc6

How reproducible:
100%

Steps to Reproduce:
1. try: mock -r fedora-devel-i386-core --debug coreutils-5.97-8.src.rpm
2.
3.
  
Actual results:
[tasaka1@localhost SRPMS]$ mock -r fedora-devel-i386-core --debug
coreutils-5.97-8.src.rpm 
Traceback (most recent call last):
  File "/usr/bin/mock", line 993, in ?
    main()
  File "/usr/bin/mock", line 988, in main
    ensure_filetype_srpm(srpms)
  File "/usr/bin/mock", line 862, in ensure_filetype_srpm
    ts = rpmUtils.transaction.initReadOnlyTransaction()
AttributeError: 'module' object has no attribute 'transaction'


Expected results:
mock can proceed.

Additional info:
Perhaps on 20060823 rawhide it was okay.
Comment 1 Kevin Fenzi 2006-08-27 12:35:07 EDT
I am seeing this as well... on two diffrent devel/rawhide systems. 
Let me know if I can help test or otherwise track down the issue. 
Comment 2 Mamoru TASAKA 2006-08-27 12:39:59 EDT
To deal with this, currently I have to downgrade yum
to FC6T2 yum(-2.9.3-2) .
Comment 3 Kevin Fenzi 2006-08-27 12:46:50 EDT
Thanks for the workaround. Even 2.9.4-4 seems to work fine, it's 2.9.5-1 thats 
causing the issue. 
Comment 4 Clark Williams 2006-08-29 10:10:26 EDT
Had to explicitly import rpmUtils.transaction due to changes in rpmUtils
Comment 5 Mamoru TASAKA 2006-08-30 02:06:33 EDT
Well;

mock-0.6.4-1.fc6 and yum-2.9.5-2 are okay.
Thank you.

Note You need to log in before you can comment on or make changes to this bug.