Bug 204061 - Red Hat Directory Server Resource Agent
Red Hat Directory Server Resource Agent
Status: CLOSED WONTFIX
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: rgmanager (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marek Grac
Cluster QE
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-25 06:47 EDT by Rob Kenna
Modified: 2009-04-16 16:23 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-15 16:36:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rob Kenna 2006-08-25 06:47:45 EDT
Resource Agent for Red Hat Directory Server with use instructions.
Comment 1 Rob Kenna 2006-09-20 12:56:58 EDT
PM ACK for 4.6 (don't think we'll get it sooner.)
Comment 2 Michael Hideo 2007-06-06 00:50:21 EDT
Adding 'cc ecs-dev-list@redhat.com for team coverage
Comment 3 Marek Grac 2007-07-24 10:59:03 EDT
I was not able to find out. How to have more than 1 instance of Directory Server
on one node. Resource agent will be really crippled without it.
Comment 4 Kiersten (Kerri) Anderson 2007-08-14 12:46:23 EDT
Moving to 4.7 for further eval.  Current recommendation is to just use the DS
init scripts.
Comment 5 Marek Grac 2007-08-15 16:36:29 EDT
Thanks to communication with developers from Fedora DS. I have additional
information. 

It is not possible to run two Fedora DS on same machine, so our approach to RA
will not work. But you can run multiple instances of DS from DS itself.
Unfortunately commands have to be written in the console of DS. There will still
be a problems because agent won't have same philosophy as others. Too much
hacking   of software. 

Solutions are:
* use only one DS per fail-over domain in cluster (potentially only DS per machine)
* run DS on the cluster but not as a service and use multi-master feature of DS
(active/active)
* run DS inside virtual machine, this virtual machine can be service of cluster,
so we will have DS as classic service without problems 1 DS per machine


Note You need to log in before you can comment on or make changes to this bug.