Bug 20407 - desktop entries
desktop entries
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gnome-core (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-06 03:09 EST by Gerald Teschl
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-04 22:53:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerald Teschl 2000-11-06 03:09:42 EST
I feel the user*.desktop entries should be moved from System to Utilities.
System should only contain administration tools for root. In particular,
In particular, a site administrator should be able to remove read access
from the System directory for regular users (if they arn't allowed to use
this
tools why not hide them in the first place).
Comment 1 Need Real Name 2002-05-30 15:38:25 EDT
Please don't.
Please don't hide any administrator's tool from regular users' menu!
I buy a RedHat Linux "Personal version" because I use it as my Personal
Computer! In fact, we should push the world to switch to use RedHat Linux as
desktop computer. Having both Windows and Linux computers co-exist is just too
much trouble for end users and developers. The world is giving us a chance to
conquere PC market, please don't reject ourselves!
You still use Windows at home?! 

John
Comment 2 Need Real Name 2002-06-02 14:23:52 EDT
This bug should be CLOSED.  But it's status is still NEW.
What do you expect a Personal Computer user to use system utilities? Log off
then log on as root? Forget about "root", folks. RedHat linux "personal" edition
means there are no system administartor in this world!! Every user is an
administrator! A regular should be able to access root's utilities as easily as
the administrator!
Comment 3 Gerald Teschl 2002-06-03 06:57:20 EDT
You totally misunderstood my request. What I want is that all tools which are
only intended for the sysadmin are in one directory such that the sysadmin
can, IF THE SYSADMIN WANTS, hide these items from regular users. I do
NOT SAY that they should be hidden in a default configuration.
Comment 4 Brent Fox 2002-06-04 22:52:44 EDT
This is really more related to desktop menu structure rather than usermode.  It
applies to Gnome as well as KDE, but I'm going to assign to Gnome since I have
to pick one.
Comment 5 Havoc Pennington 2002-07-02 17:24:18 EDT
With the way menus are done in Rawhide, this bug doesn't really apply anymore.
There's a single file you can edit to change what's in the menus, and the
folders/categories are different.

Note You need to log in before you can comment on or make changes to this bug.