Bug 204076 - Installing of lvm2-cluster modifies lvm.conf file
Installing of lvm2-cluster modifies lvm.conf file
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lvm2-cluster (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alasdair Kergon
:
: 203922 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-25 09:25 EDT by Jay Turner
Modified: 2015-01-07 19:14 EST (History)
6 users (show)

See Also:
Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-11 06:58:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Turner 2006-08-25 09:25:10 EDT
Description of problem:
Should really be filed against the lvm2-cluster package, but that's not in the
listing so figured this would get to the right place.  As part of the %post for
lvm2-cluster, we're running:

/usr/sbin/lvmconf --enable-cluster --lockinglibdir /usr/lib

which has the net effect of modifying the locking_type in the /etc/lvm/lvm.conf
file.  We should think about one of a couple of things:

1) add another option to "lvmconf" which indicates at install-time that an
/etc/lvm/lvm.conf.rpmnew (or something) file should be created as opposed to
modifying the running lvm.conf file
2) don't run the "lvmconf" command as part of the %post; is there really a need
to bring up clvm during the install?

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Alasdair Kergon 2006-08-25 09:47:49 EDT
We do want to run it at install time to ensure the conf file holds the correct
settings (incl. setting the library directory).  But placing the changes into
rpmnew would make more sense.  However this is still not sufficient: we risk
people not realising they need to change the file before using clustering and
believing they're clustered when they aren't.  Perhaps the clvmd init script
needs to fail if clustering is not enabled in the live lvm.conf file.
Comment 2 Jay Turner 2006-08-25 10:05:21 EDT
Too funny . . . when I was writing the original comment, there were three
suggestions I was going to make . . . then I forgot one.  That was to smarten up
the initscript to ensure the lvm.conf file was "correct."
Comment 3 Jay Turner 2006-08-25 10:27:59 EDT
*** Bug 203922 has been marked as a duplicate of this bug. ***
Comment 4 Alasdair Kergon 2006-08-25 11:09:31 EDT
We don't distinguish bugs beta vs. live at the moment, and 'lvm2-cluster'
package is called 'clvm' in bugzilla for historic reasons and comes under RHCS
not RHEL.  It's about time we decided to change this...
Comment 5 Alasdair Kergon 2006-08-25 11:21:56 EDT
Renamed 'clvm' to 'lvm2-cluster'.
Comment 6 Alasdair Kergon 2006-09-20 14:15:34 EDT
Well I've just rebuilt lvm2-cluster so that it no longer touches the
locking_type setting.

So to enable clustering in their lvm2 configuration after installing this
package, people just now need to run:

  lvmconf.sh --enable-cluster

lvm2-cluster-2.02.10-2.0.RHEL5

That should solve the urgent problem.
(initscript checks will have to wait till we've more time.)
Comment 7 Alasdair Kergon 2006-09-21 10:48:38 EDT
beta-blocker because of bug 204793 dependency
Comment 9 Jay Turner 2006-11-11 06:56:43 EST
Fix confirmed with lvm2-cluster-2.02.12-7.el5 which is included in the latest
RHEL5 trees.
Comment 10 Nate Straz 2007-12-13 12:24:11 EST
Moving all RHCS ver 5 bugs to RHEL 5 so we can remove RHCS v5 which never existed.

Note You need to log in before you can comment on or make changes to this bug.