Bug 204084 - SAP Resource Agent
SAP Resource Agent
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: rgmanager (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marek Grac
Cluster QE
: Documentation, Reopened
Depends On:
Blocks: 238916
  Show dependency treegraph
 
Reported: 2006-08-25 10:01 EDT by Rob Kenna
Modified: 2009-04-16 16:23 EDT (History)
12 users (show)

See Also:
Fixed In Version: RHBA-2007-1000
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-21 16:53:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
SAP ocf resource agent for Linux HA solutions (10.21 KB, application/octet-stream)
2006-10-17 11:39 EDT, Alexander Krauth
no flags Details
Check two places for ocf-shellfuncs in SAPInstance (619 bytes, patch)
2006-10-17 12:36 EDT, Lon Hohberger
no flags Details | Diff
RHEL4 rgmanager patch to choose primary attr if none is provided (1.71 KB, patch)
2006-10-17 12:37 EDT, Lon Hohberger
no flags Details | Diff
RHEL5 rgmanager patch to choose primary attr if none is provided (1.47 KB, patch)
2006-10-17 12:38 EDT, Lon Hohberger
no flags Details | Diff
SAP ocf resource agent database for Linux HA solutions (17.54 KB, text/plain)
2006-12-06 10:02 EST, Alexander Krauth
no flags Details
SAP ocf resource agent for Linux HA solutions (11.53 KB, text/plain)
2006-12-06 10:04 EST, Alexander Krauth
no flags Details
SAP ocf resource agent database for Linux HA solutions (19.82 KB, text/plain)
2007-06-21 10:16 EDT, Alexander Krauth
no flags Details
SAP ocf resource agent for Linux HA solutions (15.48 KB, text/plain)
2007-06-21 10:18 EDT, Alexander Krauth
no flags Details

  None (edit)
Description Rob Kenna 2006-08-25 10:01:52 EDT
SAP Resource Agent with use intructions.  May not be achievable in 4.5 RHCS.
Comment 2 RHEL Product and Program Management 2006-09-20 12:15:48 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request. 
Comment 4 Lon Hohberger 2006-10-17 10:44:51 EDT
This is really 3 resource agents and requires multiple dependencies, which we do
not currently have in rgmanager.  Since we are working on the multiple
dependency issue and this is not really a single bug, I'm closing this one for now.
Comment 5 Nils Philippsen 2006-10-17 11:20:26 EDT
Alexander Krauth has worked on a generic resource agent for SAP server software,
he'll attach the current revision to this BZ. Mind that this still needs
multiple dependencies, as we need to specify that an SAP appserver needs a
running SAP message server and database to be started. In the SAP case, we also
need "weak" dependencies, i.e. the dependencies are only needed for starting, it
handles reconnecting to  the message server or DBMS by itself.
Comment 6 Alexander Krauth 2006-10-17 11:39:47 EDT
Created attachment 138692 [details]
SAP ocf resource agent for Linux HA solutions
Comment 7 Alexander Krauth 2006-10-17 11:41:46 EDT
Here is the current SAP resource agent developed in the SAP LinuxLab. It is not
jet completed and not completely tested (but basicaly working). It uses SAP
Kernel 7.00 functionality which is planed to be "backported" to SAP 4.6D in the
near future. It is generic to start,stop and monitor all types of SAP instances
(systems).
Another agent called SAPdatabase will (hopefully) follow soon, which will cover
the SAP specific database features.
It is planed that both agents will also be part of the cluster ha project that
feads the heartbeat.rpm.

Cheers,
Alex
Comment 8 Lon Hohberger 2006-10-17 12:09:54 EDT
As I suspected, that agent will only require very tiny modifications in order to
work with rgmanager (ex: location of ocf-shellfuncs, for example, differs on
rgmanager vs. heartbeat).
Comment 9 Lon Hohberger 2006-10-17 12:36:24 EDT
Created attachment 138694 [details]
Check two places for ocf-shellfuncs in SAPInstance
Comment 10 Lon Hohberger 2006-10-17 12:37:30 EDT
Created attachment 138695 [details]
RHEL4 rgmanager patch to choose primary attr if none is provided
Comment 11 Lon Hohberger 2006-10-17 12:38:49 EDT
Created attachment 138696 [details]
RHEL5 rgmanager patch to choose primary attr if none is provided
Comment 12 Lon Hohberger 2006-10-17 12:43:52 EDT
With those patches, rgmanager can use the resource agent.  I haven't fully
tested it, but in cluster.conf, it would look like:

<service name="example">
  <SAPInstance InstanceName="test" DIR_EXECUTABLE="foo" DIR_PROFILE="bar"
START_PROFILE="wachattamanga"/>
  <fs .../>
  <ip .../>
</service>

Comment 13 Lon Hohberger 2006-10-17 12:54:17 EDT
Note: case sensitive!
Comment 14 Nils Philippsen 2006-10-18 03:33:58 EDT
Case sensitive is no problem because the 3 latter options are hardly if ever
used (customers use the defaults given by the SAP installer, the options are
just there for the sake of completeness, i.e. if some customer suffers from the
NIH syndrome).

Are there BZ entries that deal with the "multiple dependency" and "one service
follows another" issues?
Comment 15 Nils Philippsen 2006-10-18 03:38:03 EDT
Another question: to use that resource manager, does the <service> metadata need
to be changed, i.e. does <service> need to know that SAPInstance is a valid child?
Comment 16 Alexander Krauth 2006-12-06 10:02:57 EST
Created attachment 142956 [details]
SAP ocf resource agent database for Linux HA solutions
Comment 17 Alexander Krauth 2006-12-06 10:04:31 EST
Created attachment 142957 [details]
SAP ocf resource agent for Linux HA solutions
Comment 19 Alexander Krauth 2006-12-06 10:13:13 EST
I attached the first full functional version of the SAPInstance and SAPDatabase
resource agents. They are tested and working with the Linux-HA project
(http://www.linux-ha.org/) right now.
Tests with Red Hat Cluster Suite will follow asap.
Comment 21 Kiersten (Kerri) Anderson 2007-05-03 11:05:55 EDT
Are there any further dependencies on rgmanager that have not been resolved?
Comment 22 Michael Hideo 2007-06-06 00:47:02 EDT
Adding 'cc ecs-dev-list@redhat.com for tracking
Comment 23 Lon Hohberger 2007-06-19 15:06:44 EDT
No deps on rgmanager; SAP resource agents are in the RHEL5 branch.  I altered
the scripts themselves to add the primary="x" attribute to the metadata rather
than requiring core rgmanager changes.
Comment 24 Lon Hohberger 2007-06-21 09:46:27 EDT
All we need to do here is check the ones from the RHEL5 branch in to CVS
Comment 25 Nils Philippsen 2007-06-21 10:13:49 EDT
Alex, please attach the current versions of the SAP resource agent files to this
bug. Thanks.
Comment 27 Alexander Krauth 2007-06-21 10:16:53 EDT
Created attachment 157536 [details]
SAP ocf resource agent database for Linux HA solutions

actual version of SAPDatabase OCF agent attached
Comment 28 Alexander Krauth 2007-06-21 10:18:01 EDT
Created attachment 157537 [details]
SAP ocf resource agent for Linux HA solutions

actual version of SAPInstance OCF agent attached
Comment 29 Alexander Krauth 2007-06-21 10:20:44 EDT
Somebody who has permission:
Please set that patch named: "Check two places for ocf-shellfuncs in
SAPInstance" to obsolete.
Comment 30 Nils Philippsen 2007-06-21 10:52:42 EDT
(In reply to comment #29)
> Somebody who has permission:
> Please set that patch named: "Check two places for ocf-shellfuncs in
> SAPInstance" to obsolete.

done.
Comment 31 Lon Hohberger 2007-09-25 10:01:35 EDT
Patch in CVS
Comment 32 Lon Hohberger 2007-09-25 10:01:57 EDT
Rather, RA's from RHEL5 branch checked in to RHEL4 branch.
Comment 35 errata-xmlrpc 2007-11-21 16:53:00 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-1000.html

Note You need to log in before you can comment on or make changes to this bug.