Bug 204089 - 32 bit rollover problem for UCD-SNMP-MIB::ssCpuRaw* OIDs
32 bit rollover problem for UCD-SNMP-MIB::ssCpuRaw* OIDs
Status: CLOSED DUPLICATE of bug 223775
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: net-snmp (Show other bugs)
4.2
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Jan Safranek
http://sourceforge.net/tracker/index....
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-25 10:40 EDT by Bill Montgomery
Modified: 2007-11-16 20:14 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-04 10:21:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fixes the 32bit rollover problem for ssCpuRaw* (1.30 KB, patch)
2006-08-25 10:50 EDT, Bill Montgomery
no flags Details | Diff
ctx-intr-overflow for 5.2.1.2, after vmstat.32bit-overflow applied (1.10 KB, patch)
2006-08-25 10:51 EDT, Bill Montgomery
no flags Details | Diff

  None (edit)
Description Bill Montgomery 2006-08-25 10:40:25 EDT
Description of problem:
I'm unable to get CPU usage statistics via SNMP for some of my high-uptime
systems. This is a good description from the sf.net net-snmp bug database:

In UCD-SNMP-MIB there are some ssRawCpu* objects defined under
systemStats. I use these for RRD graphics and noticed on one machine
after several months without reboot, that ssRawCpuIdle reached
4294967295 (=2^32-1) and stayed on this instead of rolling over and
starting with 0 again like Counter32 (the type of ssRawCpuIdle) let me
expect.

Version-Release number of selected component (if applicable):
5.1.2-11.EL4.6

How reproducible:
Consistent

Steps to Reproduce:
1. Let a system accumulate more than (2^32)-1 timeticks for any field in /proc/stat
2. Query the ssRawCPU* OID in the UCD-SNMP-MIB that corresponds to said field
  
Actual results:
From the monitored system:
[billm@db03 ~]$ cat /proc/stat
cpu  2626530060 574 526603680 14709589002 19217576 9007617 54236522
cpu0 245751702 84 60232005 1926186933 2584965 1240907 7151544
cpu1 392341845 77 67960043 1772887651 2266862 1054551 6637095
cpu2 252492463 86 63314902 1916844755 2553494 1091744 6850682
cpu3 422714591 87 71430603 1739241738 2211938 1069542 6479625
cpu4 245179838 58 60358959 1926633232 2554170 1264439 7157427
cpu5 392748199 63 68429791 1771917241 2287390 1079375 6686065
cpu6 252598705 59 63468155 1916580745 2548675 1122739 6829045
cpu7 422702713 55 71409219 1739296705 2210079 1084317 6445036
intr 18683487120
ctxt 251235855639
btime 1134081588
processes 197892051
procs_running 3
procs_blocked 0

From the monitoring server:
[billm@netmon1 ~]$ snmpget -v 2c -c xxxx db03.lulu.com .1.3.6.1.4.1.2021.11.53.0
UCD-SNMP-MIB::ssCpuRawIdle.0 = Counter32: 4294967295
(Note 4294967295 is the max value for a 32-bit unsigned int)

Expected results:
UCD-SNMP-MIB::ssCpuRawIdle.0 = Counter32: [14709589002 & 0xffffffff]

Additional info:
http://sourceforge.net/tracker/index.php?func=detail&aid=1197183&group_id=12694&atid=112694
This has been fixed in version 5.1.3 of net-snmp, the patch is small and should
be easy to backport to the RHEL release of 5.1.2. The problem exists for the
context switch and interrupt OIDs, and there is a patch for those, too, attached
to the sf.net bug report.
Comment 1 Bill Montgomery 2006-08-25 10:50:29 EDT
Created attachment 134923 [details]
 Fixes the 32bit rollover problem for ssCpuRaw*

Lifted from
http://sourceforge.net/tracker/index.php?func=detail&aid=1197183&group_id=12694&atid=112694
Comment 2 Bill Montgomery 2006-08-25 10:51:37 EDT
Created attachment 134924 [details]
 ctx-intr-overflow for 5.2.1.2, after vmstat.32bit-overflow applied

Lifted from
http://sourceforge.net/tracker/index.php?func=detail&aid=1197183&group_id=12694&atid=112694
Comment 3 Jan Safranek 2007-06-04 10:21:47 EDT

*** This bug has been marked as a duplicate of 223775 ***

Note You need to log in before you can comment on or make changes to this bug.