Bug 204132 - cpuspeed startup scrips fails in unduly noisy manner
cpuspeed startup scrips fails in unduly noisy manner
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cpuspeed (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jarod Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-25 15:14 EDT by Michal Jaegermann
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-08 10:14:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix for a cpuspeed startup script (782 bytes, patch)
2006-08-25 15:14 EDT, Michal Jaegermann
no flags Details | Diff

  None (edit)
Description Michal Jaegermann 2006-08-25 15:14:28 EDT
Created attachment 134954 [details]
fix for a cpuspeed startup script
Comment 1 Michal Jaegermann 2006-08-25 15:14:28 EDT
Description of problem:

/etc/init.d/cpuspeed is turned on by default but it may fail.
At least on a start it checks for that condition but only after
it produced a message which is not really relevant in the context
(cf. bug 201463 which, in a sense, may be not a bug at all).

'service cpuspeed stop' may just fail by trying to read from a
non-existent location and here a relevant check is just missing.

Sure, one can always do 'chkconfig cpuspeed off' but maybe problems
are only temporary specific to some kernels?

Attached is a proposed patch to deal with the problem.

Version-Release number of selected component (if applicable):
cpuspeed-1.2.1-1.40.fc6

How reproducible:
always on a machine where cpuspeed does not work
Comment 2 Jarod Wilson 2007-01-08 10:14:35 EST
Eep, finally got mass-reassigned all the cpuspeed bugs over the weekend... I
believe this one is taken care of in the latest rawhide build. I like the
null-redirect on modprobing acpi-cpufreq, but not for $DRIVER. Since the user
must manually specify $DRIVER, I like spitting an error if they screwed up.

Note You need to log in before you can comment on or make changes to this bug.