Bug 204165 - continuation of bug 159706: bad management of SYSFONTACM in /sbin/setsysfont
continuation of bug 159706: bad management of SYSFONTACM in /sbin/setsysfont
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-26 05:28 EDT by Yves L'ECUYER
Modified: 2014-03-16 23:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-10 15:06:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yves L'ECUYER 2006-08-26 05:28:35 EDT
As I reported in bug 159706 for fedora core 4, to manage correctly the option
i18n in setsysfont:

BUGGY lines in
/sbin/setsysfont:
------------------------
 
    if [ ! -f /lib/kbd/consoletrans/$SYSFONTACM_to_uni.trans ]; then
        SYSFONTACM=`echo $SYSFONTACM | sed "s|iso0|8859-|g;s|iso|8859-|g"`
    fi
 
  fi


must become:
  
    if [ ! -f /lib/kbd/consoletrans/${SYSFONTACM}_to_uni.trans ]; then
        SYSFONTACM=`echo $SYSFONTACM | sed "s/iso0/8859-/g;s/iso/8859-/g"`
    fi

Unfortunately, in fedora 5 only the first line is corrected, but in the second
line, the pattern matching for sed expression is STILL with pipe "|" instead of
"/", so processing of SYSFONTACM still doesn't work !
Comment 1 Bill Nottingham 2006-10-18 17:00:19 EDT
I can't reproduce this here - setting SYSFONTACM to (for example) iso15 works,
in that I get 8859-15 out.

Note that this is, in essence, supporting a config written by pre-kbd packages,
which is a few years ago at this point.
Comment 2 Miloslav Trmač 2006-11-10 15:06:48 EST
The sed 's' command can use any characer as a separator, not only a slash.

Note You need to log in before you can comment on or make changes to this bug.