Bug 2041712 - Unable to install azure-cli 2.32.0 on Fedora35
Summary: Unable to install azure-cli 2.32.0 on Fedora35
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: azure-cli
Version: 35
Hardware: noarch
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Major Hayden 🤠
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-01-18 07:09 UTC by Ryan
Modified: 2022-01-29 06:38 UTC (History)
1 user (show)

Fixed In Version: azure-cli-2.32.0-7.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-01-29 06:38:02 UTC
Type: Bug


Attachments (Terms of Use)

Description Ryan 2022-01-18 07:09:27 UTC
Description of problem:
Unable to install azure-cli 2.32 (updates-testing) on Fedora 35 due to broken depends

Version-Release number of selected component (if applicable):
current: 2.30.0-5.fc35.noarch
attempted: 2.32.0-3.fc35.noarch

How reproducible:
every time

Steps to Reproduce:
1. with azure-cli 2.30.0-5 installed from stable
2. sudo dnf upgrade azure-cli --enablerepo updates-testing

Actual results:
Problem: problem with installed package azure-cli-2.30.0-5.fc35.noarch
  - cannot install the best update candidate for package azure-cli-2.30.0-5.fc35.noarch
  - package azure-cli-2.32.0-3.fc35.noarch requires python3.10dist(azure-cli-core) = 2.32, but none of the providers can be installed
  - nothing provides (python3.10dist(humanfriendly) >= 10 with python3.10dist(humanfriendly) < 11) needed by python3-azure-cli-core-2.32.0-3.fc35.noarch

Expected results:
successful package upgrade

Additional info:
I installed azure-cli this morning for the first time

Comment 1 Ryan 2022-01-18 07:17:19 UTC
Noted on bodhi (https://bodhi.fedoraproject.org/updates/FEDORA-2022-8d0db8f648) that 2.32.0-5 was pushed to rectify, pending this to sync to downstream mirrors to determine if issue resolved

Comment 2 Ryan 2022-01-18 07:20:23 UTC
assuming the tags are fixed on the package as per the last entry from bodhi:

FEDORA-2022-8d0db8f648 ejected from the push because "Cannot find relevant tag for azure-cli-2.32.0-5.fc35. None of ['f35-updates-testing-pending', 'f35-build-side-49268'] are in ['epel9-next-testing-candidate', 'epel7-testing-candidate', 'dist-5E-epel-testing-candidate', 'f27-modular-updates-candidate', 'f34-container-updates-candidate', 'eln-updates-candidate', 'f30-modular-updates-candidate', 'f28-modular-updates-candidate', 'f28-container-updates-candidate', 'f30-container-updates-candidate', 'epel8-testing-candidate', 'f30-flatpak-updates-candidate', 'f35-container-updates-candidate', 'f32-modular-updates-candidate', 'f29-modular-updates-candidate', 'f29-container-updates-candidate', 'f29-flatpak-updates-candidate', 'f22-updates-candidate', 'f21-updates-candidate', 'f25-updates-candidate', 'f24-updates-candidate', 'f23-updates-candidate', 'f26-updates-candidate', 'f31-modular-updates-candidate', 'dist-6E-epel-testing-candidate', 'f32-flatpak-updates-candidate', 'f35-flatpak-updates-candidate', 'f27-updates-candidate', 'f28-updates-candidate', 'f30-updates-candidate', 'f29-updates-candidate', 'el8-modular-updates-candidate', 'f32-updates-candidate', 'epel9-testing-candidate', 'f31-updates-candidate', 'f31-container-updates-candidate', 'f31-flatpak-updates-candidate', 'f34-updates-candidate', 'f34-modular-updates-candidate', 'f34-flatpak-updates-candidate', 'f36-container-updates-candidate', 'f32-container-updates-candidate', 'epel8-next-testing-candidate', 'f35-updates-candidate', 'f35-modular-updates-candidate', 'f33-updates-candidate', 'f36-updates-candidate', 'f33-modular-updates-candidate', 'f33-container-updates-candidate', 'f33-flatpak-updates-candidate']."

Comment 3 Major Hayden 🤠 2022-01-18 12:39:24 UTC
Hey Ryan -- thanks for pointing this out. There was a hiccup in the requirements for python-humanfriendly (which I'm still begging the maintainer to update in F35), but this should be fixed in F35 testing now. I just gave it a try with:

$ podman run --rm -it --pull=always registry.fedoraproject.org/fedora:35 dnf --enablerepo=updates-testing -qy install azure-cli
Trying to pull registry.fedoraproject.org/fedora:35...
Getting image source signatures
Copying blob 4545346f2a49 skipped: already exists
Copying config 3059bef432 done
Writing manifest to image destination
Storing signatures

Installed:
  azure-cli-2.30.0-5.fc35.noarch

Let me know if you're still seeing an issue on your end and I can dig further.

Comment 4 Ryan 2022-01-20 00:48:00 UTC
"Installed:
  azure-cli-2.30.0-5.fc35.noarch"

As noted in Bodhi for this update:

"I can't test the 2.32.0-5 update as it was ejected from updates-testing due to tags.

Note that I can install from the build files, but I still get dependency problems with python3-azure-mgmt-iotcentral that require a `--best --allowerasing` switch in dnf"

Comment 5 Ryan 2022-01-20 00:49:55 UTC
The dependency problem with python3-azure-mgmt-iotcentral seems to be that Fedora doesn't recognise it as the release version of 9.0.0b1-2

Comment 6 Major Hayden 🤠 2022-01-20 14:12:24 UTC
Ah, I see what you're saying now. I forgot to add a tilde to the `b1` version and now it sorts incorrectly with 9.0.0's final release. 🤦🏻‍♂️

I marked the bodhi update obsolete and I'm fixing the iotcentral package.

Comment 7 Fedora Update System 2022-01-20 18:05:27 UTC
FEDORA-2022-be7f1b322a has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2022-be7f1b322a

Comment 8 Fedora Update System 2022-01-21 18:52:41 UTC
FEDORA-2022-be7f1b322a has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-be7f1b322a`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-be7f1b322a

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Ryan 2022-01-24 00:59:35 UTC
It's looking like this update will do the job, going to test from a toolbox and then I'll flick an update on bodhi :)

Comment 10 Ryan 2022-01-24 01:07:50 UTC
working for me, happy to close, thanks for your assistance :)

Comment 11 Fedora Update System 2022-01-29 06:38:02 UTC
FEDORA-2022-be7f1b322a has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.