Bug 204181 - could we have sfdisk back please during kickstart?
could we have sfdisk back please during kickstart?
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-26 10:17 EDT by W Agtail
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-28 13:36:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description W Agtail 2006-08-26 10:17:10 EDT
Description of problem:
sfdisk has gone, could we have it back?

Version-Release number of selected component (if applicable):
devel release as of today

How reproducible:
always

Steps to Reproduce:
I like to partition disk during %pre stage in kickstart with something like:
%pre
parted -s /dev/sda mklabel msdos
sfdisk /dev/sda << EOF
,256,L
,16,L
,256,L
EOF
  
Actual results:
sfdisk not found

Expected results:
sfdisk to be found :)

Additional info:

When trying to use parted to partition disk, you end up with strange cyclinder
boundaries. e.g:
parted -s /dev/sdb mklabel msdos
parted -s /dev/sdb mkpart primary 0    4096
parted -s /dev/sdb mkpart primary 4096 4608
parted -s /dev/sdb mkpart primary 4608 6656
Comment 1 David Cantrell 2006-08-28 12:01:30 EDT
Define strange.
Comment 2 W Agtail 2006-08-28 16:09:08 EDT
With the above parted example, fdisk -l reports:
Partition 2 does not end on cylinder boundary.
Partition 3 does not end on cylinder boundary.

Any reason why we can't have sfdisk back?

Manyu thanks, W Agtail
Comment 3 David Cantrell 2006-08-29 10:53:37 EDT
I guess I don't see the point other than just wanting it because it's been your
preferred tool for a long time.  Not that there's anything wrong with that, but
here's my position on it:

The fewer partitioning tools we include, the easier it is to fix partitioning
bugs.  I'd much prefer you to use anaconda to do the partitioning (which uses
parted), or use parted directly.  Is there a reason you aren't using anaconda's
partitioning commands?  Do they not work for your case?

If I add sfdisk to the install image and then you use it for kickstart installs
and then it fails, it's unlikely we'll fix that and instead tell you to use
parted or use anaconda's partitioning features directly.
Comment 4 W Agtail 2006-08-29 13:04:13 EDT
OK, I see your point with supporting multiple partitioning tools. Would it be
possible to either fix parted, so that its "aware" of cylinder boundaries (thus
above mentioned warning/errors are not displayed), or my preferred option would
be to add another option to parted which would allow "start" & "end" values to
be specified in cylinders rather than having to always use megabytes?

From the parted man pages:
mkpart part-type [fs-type] start end
make a part-type partition with filesystem fs-type (if specified), beginning at
start and ending at end (in megabytes). part-type should be one of "primary",
"logical" or "extended"

Thanks again...
Comment 5 David Cantrell 2006-09-28 13:36:36 EDT
Fixing parted is my preferred solution.  I'm going to close this bug rather than
reassign to parted because it's incredibly difficult to follow bug reassignments
like this.  This bug is really 'can we add sfdisk back' to which the answer is
WONTFIX.

Can you open a bug against parted describing what feature is missing that you
want added?

Thanks,

Note You need to log in before you can comment on or make changes to this bug.