Bug 204197 - coolkey demo: thunderbird problems if 2 esc processes are running
coolkey demo: thunderbird problems if 2 esc processes are running
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: esc (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jack Magne
Chandrasekar Kannan
RHEL5.0NACK
:
Depends On:
Blocks: 202042
  Show dependency treegraph
 
Reported: 2006-08-26 12:01 EDT by Chandrasekar Kannan
Modified: 2015-01-04 18:20 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-17 17:11:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chandrasekar Kannan 2006-08-26 12:01:52 EDT
migrated from http://raidzilla.sfbay.redhat.com/show_bug.cgi?id=57869  

rich encountered this problem when performing the coolkey demo:

seems like it could be because he had two ESC processes running. we should
prevent esc from being launched multiple times.


-------------------------
So the problem was that ESC was still running.  I created an app launcher for
ESC so that I wouldn't have to show the terminal window with all of the warning
messages.  What I didn't realize was that ESC does not exit when you press the X
to close the window.  There is still a task icon for ESC which you have to
select with the right mouse and select Exit from the menu in order to fully exit
the application.  What was weird was that the web auth part of the demo worked
fine, but the thunderbird demo would not work - it would recognize the device as
my certificate, but would not use it for Other People's certificates.

Anyway, problem solved and it's working fine. 

-------------------------


------- Additional Comment #1 From Chandrasekar Kannan 2006-08-20 14:55 [reply]
-------

per bug council on 08/18/2006, future
Comment 1 Jack Magne 2006-09-12 14:00:37 EDT
Make sure that it is not possible for more than one ESC process to start. The
currently observed behavior is that this is not possible. When ESC is launched
from the menu on Linux, ESC simple brings up the "Manage Smart Cards" page.

Also, need to make sure this behavior holds for Mac and Windows.
Comment 2 Chandrasekar Kannan 2006-11-21 00:46:32 EST
per bug council on 11/17, these bugs are not targeted for RHEL 5.0 Smart card
login work. These bugs will now be targeted for RHEL 5.1. 

Comment 3 Chandrasekar Kannan 2007-03-20 07:14:19 EDT
per the last bug meeting, we decided this would be targeted in the rhel 5.1
release. 
Comment 4 Bob Lord 2007-03-28 13:27:21 EDT
This bug was proposed for RHEL 5, but wasn't resolved in time.
    devel_ack+ for RHEL 5.1.
Comment 5 Scott Haines 2007-08-17 17:11:45 EDT
This bug is not reproducible anymore.

Note You need to log in before you can comment on or make changes to this bug.