Bug 204207 - Fedora Core updates should include debuginfo RPMs
Summary: Fedora Core updates should include debuginfo RPMs
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: yum   
(Show other bugs)
Version: 5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-08-26 20:55 UTC by Eric Smith
Modified: 2014-01-21 22:54 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-26 22:56:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Eric Smith 2006-08-26 20:55:49 UTC
Published Fedora Core updates should include the debuginfo RPMs, so that a yum
update can update the debuginfo as well as the base package.

For example, on a machine I'm using for software development, I recently did an
update which upgraded to a new gtk2 package, but the debuginfo was not upgraded,
so I had to download the SRPM and build the package myself, when all I needed
was the debuginfo which was created when the package was built for distribution.

Since Bugzilla forces me to select a component, I'm entering this under yum, but
it's not actually a bug in yum (as far as I know; since the updates directory
doesn't include debuginfo packages, I can't test whether yum will update them).

Comment 1 Seth Vidal 2006-08-26 22:56:29 UTC
look in your /etc/yum.repos.d/fedora-updates.repo

you should have an entry named [updates-debuginfo]

if you enable that entry then you will have them.

I just checked on my fc5 box and it's there.


Note You need to log in before you can comment on or make changes to this bug.