Bug 204208 - latest release has some module issues
latest release has some module issues
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: perl (Show other bugs)
4.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
David Lawrence
: Rebase
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-26 17:58 EDT by justin
Modified: 2008-09-17 08:50 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-17 08:50:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description justin 2006-08-26 17:58:31 EDT
Description of problem:


Version-Release number of selected component (if applicable):

The one that just rolled out, 5.8.5-36.

How reproducible:

Not hard to find.  

Steps to Reproduce:
1.  perl -MScalar::Util=weaken -e 'weaken($var);'
2.
3.
  
Actual results:

<snip>
Weak references are not implemented in the version of perl at -e line 0
BEGIN failed--compilation aborted.
</snip>
(no too great)

Expected results:

<snip>
</snip>
(it works)

Additional info:

I'm curious as to the reason for this?  According to some others I spoke to this
is not the first time this has happened.  

Also, I believe, although I didn't verify, that this build rolled Storable back
on my box.  I had the current v2.7 installed.  But when I ran CPAN.pm to install
a normal Scalar::Util Storable reported that it was 2.6 but the file was 2.7.
Comment 1 Robin Norwood 2006-08-27 19:17:18 EDT
wrt to the Scalar::Util issue - I can't reproduce it on any of my RHEL4 machines - 

[rnorwood@metropolis ~]$ perl -MScalar::Util=weaken -e 'weaken($var);'
[rnorwood@metropolis ~]$ rpm -q perl
perl-5.8.5-36.RHEL4
[rnorwood@metropolis ~]$ rpm -V perl
[rnorwood@metropolis ~]$ cat /etc/redhat-release
Red Hat Enterprise Linux AS release 4 (Nahant Update 4)

Can you give me some hints to reproduce this - or perhaps there's something 'up'
with your test system.

Thanks,

-RN
Comment 2 Charlton Wilbur 2007-04-18 11:05:36 EDT
Happened here, too.

Red Hat Enterprise Linux ES release 4 (Nahant Update 4)

perl -e 'use Scalar::Util qw/weaken/;'

results:
Weak references are not implemented in the version of perl at -e line 0
BEGIN failed--compilation aborted.

(same as above)

The simple fix --

sudo cpan -f Scalar::Util

(perl obligingly replaces the broken Scalar::Util with an up-to-date one.)
Comment 3 justin 2007-04-18 13:52:18 EDT
Uh, OK...  Yeah, that's what I did before I submitted this bug report to get my
installs working.  But that's not a fix - its a work around.  The bug is that
the Redhat packaged version of Scalar::Util is built incorrectly.  Thanks for
documenting the workaround.  I probably should have included it in the original
report so other people could get past this faster.  
Comment 4 Peter E. Popovich 2008-01-06 18:51:48 EST
I encountered this, on a box where someone had probably used CPAN.

There were two versions of Scalar::Util and List::Util in @INC.  The first was
the CPAN version, the second was the RPM version.  Removing the CPAN version
solved the problem for me.

You can pretty easily find the files to remove by running something like this:

find /usr/lib* -path '*/Scalar/Util.pm' | xargs rpm -qf | grep 'not owned'
find /usr/lib* -path '*/List/Util.pm' | xargs rpm -qf | grep 'not owned'
Comment 5 Marcela Mašláňová 2008-08-13 09:40:48 EDT
#4 that's correct. The mixed up executables from cpan and rpm are the problem.

The correct solution is change installation paths, which is impossible for stable major releases. So I can update those two often mentioned modules on the latest version.
Comment 6 RHEL Product and Program Management 2008-09-05 13:09:34 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 8 RHEL Product and Program Management 2008-09-17 08:50:58 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.