Bug 2042108 - SELinux is preventing gdk-pixbuf-thum from 'write' accesses on the sock_file bus.
Summary: SELinux is preventing gdk-pixbuf-thum from 'write' accesses on the sock_file ...
Keywords:
Status: CLOSED DUPLICATE of bug 2042696
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 35
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Zdenek Pytela
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:2ff9962210dea5a3614fee42bce...
: 2044494 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-01-18 20:18 UTC by scroolik
Modified: 2022-01-25 16:59 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-01-25 16:59:32 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description scroolik 2022-01-18 20:18:43 UTC
Description of problem:
Opened nemo.
SELinux is preventing gdk-pixbuf-thum from 'write' accesses on the sock_file bus.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that gdk-pixbuf-thum should be allowed write access on the bus sock_file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'gdk-pixbuf-thum' --raw | audit2allow -M my-gdkpixbufthum
# semodule -X 300 -i my-gdkpixbufthum.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:session_dbusd_tmp_t:s0
Target Objects                bus [ sock_file ]
Source                        gdk-pixbuf-thum
Source Path                   gdk-pixbuf-thum
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
SELinux Policy RPM            selinux-policy-targeted-35.9-1.fc35.noarch
Local Policy RPM              selinux-policy-targeted-35.9-1.fc35.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 5.15.14-200.fc35.x86_64 #1 SMP Tue
                              Jan 11 16:49:27 UTC 2022 x86_64 x86_64
Alert Count                   11
First Seen                    2022-01-18 21:10:11 CET
Last Seen                     2022-01-18 21:17:32 CET
Local ID                      6b04d017-14c7-4a92-badf-303b7dae1c29

Raw Audit Messages
type=AVC msg=audit(1642537052.332:504): avc:  denied  { write } for  pid=9372 comm="gdk-pixbuf-thum" name="bus" dev="tmpfs" ino=60 scontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:session_dbusd_tmp_t:s0 tclass=sock_file permissive=0


Hash: gdk-pixbuf-thum,thumb_t,session_dbusd_tmp_t,sock_file,write

Version-Release number of selected component:
selinux-policy-targeted-35.9-1.fc35.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.15.2
hashmarkername: setroubleshoot
kernel:         5.15.14-200.fc35.x86_64
type:           libreport

Potential duplicate: bug 2039682

Comment 1 Will B 2022-01-24 17:09:32 UTC
*** Bug 2044494 has been marked as a duplicate of this bug. ***

Comment 2 Vitaly 2022-01-25 16:07:08 UTC
Similar problem has been detected:

Start Caja

hashmarkername: setroubleshoot
kernel:         5.15.16-200.fc35.x86_64
package:        selinux-policy-targeted-35.11-1.fc35.noarch
reason:         SELinux is preventing gdk-pixbuf-thum from 'write' accesses on the sock_file bus.
type:           libreport

Comment 3 Zdenek Pytela 2022-01-25 16:59:32 UTC

*** This bug has been marked as a duplicate of bug 2042696 ***


Note You need to log in before you can comment on or make changes to this bug.