Bug 204220 - fc5/xen/iptables kernel panic
fc5/xen/iptables kernel panic
Status: CLOSED DUPLICATE of bug 206630
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
5
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Herbert Xu
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-27 02:06 EDT by Dave Bradley
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-20 21:06:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Crash dump (4.51 KB, text/plain)
2006-09-20 01:56 EDT, Ville Lindfors
no flags Details

  None (edit)
Description Dave Bradley 2006-08-27 02:06:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

Description of problem:
The current rpms of kernel 2.6.17-1.2174_FC5xen0 and xen-3.0.2-3.FC5 seem
to have a problem. If I use shorewall to create a set of iptables rules
and xend is running, I get a kernel panic whenever network IO occurs,
usually within seconds. If I shut xend down, no panic. The shorewall/iptables rules are relatively minimal.

As an experiment, I installed the fc6 kernel -- 2.6.17-1.2517.fc6xen as
well as the somewhat later fc6 kernel and the problem was solved. However,
due to the mismatch between the kernel and xen (and the fact this is an
fc5 system), no guests will start. They crash right when init should be
starting.

So, somewhere between the 2174 and 2517 kernel versions, this bug was
fixed but is not available as an fc5 rpm set. Hence, there doesn't seem to
be a working fc5/xen/iptables combo available. Or maybe there is something
else wrong on the system. Given the 2517 kernel solved the problem, this
seems unlikely.

Version-Release number of selected component (if applicable):
kernel-xen0-2.6.17-1.2174_FC5

How reproducible:
Always


Steps to Reproduce:
1. Boot 2.6.17-1.2174_FC5xen0 kernel
2. start xend
3. start shorewall
4. attempt network connector (ssh, samba)


Actual Results:
Kernel panic and then a reboot

Expected Results:
no crash

Additional info:
Here's the output from dmesg:

Linux version 2.6.17-1.2174_FC5xen0 (brewbuilder@hs20-bc2-3.build.redhat.com) (gcc version 4.1.1 20060525 (Red Hat 4.1.1-1)) #1 SMP Tue Aug 8 17:03:19 EDT 2006
BIOS-provided physical RAM map:
 Xen: 0000000000000000 - 000000003b351000 (usable)
115MB HIGHMEM available.
831MB LOWMEM available.
Using x86 segment limits to approximate NX protection
On node 0 totalpages: 242513
  DMA zone: 212990 pages, LIFO batch:31
  HighMem zone: 29523 pages, LIFO batch:7
DMI 2.3 present.
ACPI: RSDP (v000 AMI                                   ) @ 0x000fa340
ACPI: RSDT (v001 AMIINT SiS735XX 0x00001000 MSFT 0x0100000b) @ 0x3fff0000
ACPI: FADT (v001 AMIINT SiS735XX 0x00001000 MSFT 0x0100000b) @ 0x3fff0030
ACPI: DSDT (v001    SiS      735 0x00000100 MSFT 0x0100000d) @ 0x00000000
Allocating PCI resources starting at 50000000 (gap: 40000000:bec00000)
Built 1 zonelists
Kernel command line: ro root=/dev/hda2
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Initializing CPU#0
PID hash table entries: 4096 (order: 12, 16384 bytes)
Xen reported: 1460.474 MHz processor.
Console: colour VGA+ 80x25
Dentry cache hash table entries: 131072 (order: 7, 524288 bytes)
Inode-cache hash table entries: 65536 (order: 6, 262144 bytes)
Software IO TLB enabled: 
 Aperture:     2 megabytes
 Kernel range: 0x00000000c01c7000 - 0x00000000c03c7000
vmalloc area: f4800000-fb3fe000, maxmem 33ffe000
Memory: 941888k/970052k available (2084k kernel code, 19444k reserved, 843k data, 172k init, 118092k highmem)
Checking if this processor honours the WP bit even in supervisor mode... Ok.
Calibrating delay using timer specific routine.. 3654.26 BogoMIPS (lpj=7308532)
Security Framework v1.0.0 initialized
SELinux:  Initializing.
SELinux:  Starting in permissive mode
selinux_register_security:  Registering secondary module capability
Capability LSM initialized as secondary
Mount-cache hash table entries: 512
CPU: After generic identify, caps: 0383d1f1 c1c3f9ff 00000000 00000000 00000000 00000000 00000000
CPU: After vendor identify, caps: 0383d1f1 c1c3f9ff 00000000 00000000 00000000 00000000 00000000
CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
CPU: L2 Cache: 256K (64 bytes/line)
CPU: After all inits, caps: 0383d1f1 c1c3f9ff 00000000 00000420 00000000 00000000 00000000
Checking 'hlt' instruction... OK.
SMP alternatives: switching to UP code
Freeing SMP alternatives: 16k freed
ACPI: setting ELCR to 0200 (from 0838)
Brought up 1 CPUs
checking if image is initramfs... it is
Freeing initrd memory: 3453k freed
Grant table initialized
NET: Registered protocol family 16
ACPI: bus type pci registered
PCI: Using configuration type 1
ACPI: Subsystem revision 20060127
ACPI: Interpreter enabled
ACPI: Using PIC for interrupt routing
ACPI: PCI Root Bridge [PCI0] (0000:00)
PCI: Probing PCI hardware (bus 00)
Uncovering SIS18 that hid as a SIS503 (compatible=1)
Enabling SiS 96x SMBus.
Boot video device is 0000:01:00.0
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
ACPI: Power Resource [URP1] (off)
ACPI: Power Resource [URP2] (off)
ACPI: Power Resource [FDDP] (off)
ACPI: Power Resource [LPTP] (off)
ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 *5 7 10 11 12 14 15)
ACPI: PCI Interrupt Link [LNKB] (IRQs *3 4 5 7 10 11 12 14 15)
ACPI: PCI Interrupt Link [LNKC] (IRQs 3 4 5 7 10 11 12 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LNKD] (IRQs 3 *4 5 7 10 11 12 14 15)
ACPI: PCI Interrupt Link [LNKE] (IRQs 3 4 5 7 10 11 12 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LNKF] (IRQs 3 4 5 7 10 11 12 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LNKG] (IRQs 3 4 5 7 10 *11 12 14 15)
ACPI: PCI Interrupt Link [LNKH] (IRQs 3 4 5 7 10 11 12 14 15) *0, disabled.
Linux Plug and Play Support v0.97 (c) Adam Belay
pnp: PnP ACPI init
pnp: PnP ACPI: found 11 devices
xen_mem: Initialising balloon driver.
usbcore: registered new driver usbfs
usbcore: registered new driver hub
PCI: Using ACPI for IRQ routing
PCI: If a device doesn't work, try "pci=routeirq".  If it helps, post a report
PCI: Bridge: 0000:00:01.0
  IO window: 9000-9fff
  MEM window: cfd00000-cfdfffff
  PREFETCH window: bfb00000-cfbfffff
NET: Registered protocol family 2
IP route cache hash table entries: 32768 (order: 5, 131072 bytes)
TCP established hash table entries: 131072 (order: 9, 2621440 bytes)
TCP bind hash table entries: 65536 (order: 8, 1310720 bytes)
TCP: Hash tables configured (established 131072 bind 65536)
TCP reno registered
IA-32 Microcode Update Driver: v1.14-xen <tigran@veritas.com>
audit: initializing netlink socket (disabled)
audit(1156610866.700:1): initialized
highmem bounce pool size: 64 pages
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
SELinux:  Registering netfilter hooks
Initializing Cryptographic API
ksign: Installing public key data
Loading keyring
- Added public key 159031EDF350496D
- User ID: Red Hat, Inc. (Kernel Module GPG key)
io scheduler noop registered
io scheduler anticipatory registered
io scheduler deadline registered
io scheduler cfq registered (default)
Real Time Clock Driver v1.12ac
Non-volatile memory driver v1.2
Linux agpgart interface v0.101 (c) Dave Jones
agpgart: Detected SiS 735 chipset
agpgart: AGP aperture is 64M @ 0xd0000000
RAMDISK driver initialized: 16 RAM disks of 16384K size 1024 blocksize
Xen virtual console successfully installed as ttyS0
Event-channel device installed.
blkif_init: reqs=64, pages=704, mmap_vstart=0xf3400000
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
SIS5513: IDE controller at PCI slot 0000:00:02.5
SIS5513: chipset revision 208
SIS5513: not 100% native mode: will probe irqs later
SIS5513: SiS735 ATA 100 (2nd gen) controller
    ide0: BM-DMA at 0xff00-0xff07, BIOS settings: hda:DMA, hdb:DMA
    ide1: BM-DMA at 0xff08-0xff0f, BIOS settings: hdc:DMA, hdd:DMA
Probing IDE interface ide0...
hda: Maxtor 6Y200P0, ATA DISK drive
hdb: Maxtor 6Y060L0, ATA DISK drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
Probing IDE interface ide1...
hdc: ST3200822A, ATA DISK drive
hdd: ST3200822A, ATA DISK drive
ide1 at 0x170-0x177,0x376 on irq 15
SiI680: IDE controller at PCI slot 0000:00:0b.0
ACPI: PCI Interrupt Link [LNKB] enabled at IRQ 3
PCI: setting IRQ 3 as level-triggered
ACPI: PCI Interrupt 0000:00:0b.0[A] -> Link [LNKB] -> GSI 3 (level, low) -> IRQ 3
SiI680: chipset revision 2
SiI680: BASE CLOCK == 133
SiI680: 100% native mode on irq 3
    ide2: MMIO-DMA , BIOS settings: hde:pio, hdf:pio
    ide3: MMIO-DMA , BIOS settings: hdg:pio, hdh:pio
Probing IDE interface ide2...
hde: SONY CD-ROM CDU5221, ATAPI CD/DVD-ROM drive
ide2 at 0xf480ef80-0xf480ef87,0xf480ef8a on irq 3
Probing IDE interface ide3...
Probing IDE interface ide3...
hda: max request size: 512KiB
hda: 398297088 sectors (203928 MB) w/7936KiB Cache, CHS=24792/255/63, UDMA(100)
hda: cache flushes supported
 hda: hda1 hda2 hda3 hda4
hdb: max request size: 128KiB
hdb: 120103200 sectors (61492 MB) w/2048KiB Cache, CHS=65535/16/63, UDMA(100)
hdb: cache flushes supported
 hdb: hdb1
hdc: max request size: 512KiB
hdc: 390721968 sectors (200049 MB) w/8192KiB Cache, CHS=24321/255/63, UDMA(100)
hdc: cache flushes supported
 hdc: hdc1 hdc2 hdc3
hdd: max request size: 512KiB
hdd: 390721968 sectors (200049 MB) w/8192KiB Cache, CHS=24321/255/63, UDMA(100)
hdd: cache flushes supported
 hdd: hdd1 hdd2 hdd3
hde: ATAPI 40X CD-ROM drive, 128kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.20
ide-floppy driver 0.99.newide
usbcore: registered new driver libusual
usbcore: registered new driver hiddev
usbcore: registered new driver usbhid
drivers/usb/input/hid-core.c: v2.6:USB HID core driver
PNP: PS/2 Controller [PNP0303:PS2K,PNP0f03:PS2M] at 0x60,0x64 irq 1,12
serio: i8042 AUX port at 0x60,0x64 irq 12
serio: i8042 KBD port at 0x60,0x64 irq 1
mice: PS/2 mouse device common for all mice
md: md driver 0.90.3 MAX_MD_DEVS=256, MD_SB_DISKS=27
md: bitmap version 4.39
TCP bic registered
Initializing IPsec netlink socket
NET: Registered protocol family 1
NET: Registered protocol family 17
powernow-k8: Processor cpuid 680 not supported
Using IPI No-Shortcut mode
Freeing unused kernel memory: 172k freed
input: AT Translated Set 2 keyboard as /class/input/input0
input: ImPS/2 Generic Wheel Mouse as /class/input/input1
raid5: automatically using best checksumming function: pIII_sse
   pIII_sse  :  5278.000 MB/sec
raid5: using function: pIII_sse (5278.000 MB/sec)
md: raid5 personality registered for level 5
md: raid4 personality registered for level 4
device-mapper: 4.6.0-ioctl (2006-02-17) initialised: dm-devel@redhat.com
md: Autodetecting RAID arrays.
md: autorun ...
md: considering hdd3 ...
md:  adding hdd3 ...
md:  adding hdc3 ...
md:  adding hda3 ...
md: created md0
md: bind<hda3>
md: bind<hdc3>
md: bind<hdd3>
md: running: <hdd3><hdc3><hda3>
raid5: device hdd3 operational as raid disk 2
raid5: device hdc3 operational as raid disk 1
raid5: device hda3 operational as raid disk 0
raid5: allocated 3166kB for md0
raid5: raid level 5 set md0 active with 3 out of 3 devices, algorithm 2
RAID5 conf printout:
 --- rd:3 wd:3 fd:0
 disk 0, o:1, dev:hda3
 disk 1, o:1, dev:hdc3
 disk 2, o:1, dev:hdd3
md: ... autorun DONE.
kjournald starting.  Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
SELinux:  Disabled at runtime.
SELinux:  Unregistering netfilter hooks
audit(1156610873.180:2): selinux=0 auid=4294967295
r8169 Gigabit Ethernet driver 2.2LK-NAPI loaded
ACPI: PCI Interrupt Link [LNKD] enabled at IRQ 4
PCI: setting IRQ 4 as level-triggered
ACPI: PCI Interrupt 0000:00:0f.0[A] -> Link [LNKD] -> GSI 4 (level, low) -> IRQ 4
eth0: Identified chip type is 'RTL8169s/8110s'.
eth0: RTL8169 at 0xf486ee00, 00:0f:b5:81:b4:8b, IRQ 4
sis900.c: v1.08.09 Sep. 19 2005
ACPI: PCI Interrupt Link [LNKG] enabled at IRQ 11
PCI: setting IRQ 11 as level-triggered
ACPI: PCI Interrupt 0000:00:03.0[A] -> Link [LNKG] -> GSI 11 (level, low) -> IRQ 11
0000:00:03.0: Realtek RTL8201 PHY transceiver found at address 1.
0000:00:03.0: Using transceiver found at address 1 as default
eth1: SiS 900 PCI Fast Ethernet at 0xc800, IRQ 11, 00:07:95:38:a8:e0.
sis630_smbus 0000:00:02.0: SIS630 comp. bus not detected, module not inserted.
sis96x_smbus 0000:00:02.1: SiS96x SMBus base address: 0x0c00
parport: PnPBIOS parport detected.
parport0: PC-style at 0x378, irq 7 [PCSPP,TRISTATE]
lp0: using parport0 (interrupt-driven).
lp0: console ready
ACPI: Power Button (FF) [PWRF]
ACPI: Sleep Button (CM) [SLPB]
ibm_acpi: ec object not found
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
EXT3 FS on hda2, internal journal
kjournald starting.  Commit interval 5 seconds
EXT3 FS on hda1, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting.  Commit interval 5 seconds
EXT3 FS on dm-0, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting.  Commit interval 5 seconds
EXT3 FS on dm-1, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting.  Commit interval 5 seconds
EXT3 FS on dm-2, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting.  Commit interval 5 seconds
EXT3 FS on dm-3, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting.  Commit interval 5 seconds
EXT3 FS on dm-12, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting.  Commit interval 5 seconds
EXT3 FS on dm-9, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
Adding 2097144k swap on /dev/raid5/swap.  Priority:-1 extents:1 across:2097144k
r8169: eth0: link up
eth1: Media Link On 100mbps full-duplex 
audit(1156636127.277:3): audit_pid=1634 old=0 by auid=4294967295
Bluetooth: Core ver 2.8
NET: Registered protocol family 31
Bluetooth: HCI device and connection manager initialized
Bluetooth: HCI socket layer initialized
Bluetooth: L2CAP ver 2.8
Bluetooth: L2CAP socket layer initialized
Bluetooth: HIDP (Human Interface Emulation) ver 1.1
it87: Found IT8705F chip at 0x290, revision 2
NET: Registered protocol family 10
lo: Disabled Privacy Extensions
IPv6 over IPv4 tunneling driver
eth0: no IPv6 routers present
eth1: no IPv6 routers present
Bridge firewalling registered

Here's a list of modules loaded before the crash:

xt_tcpudp               7233  13 
xt_state                6209  8 
xt_pkttype              5953  4 
iptable_raw             6209  0 
xt_CLASSIFY             5953  0 
xt_CONNMARK             6465  0 
xt_MARK                 6465  0 
xt_length               6081  0 
xt_connmark             6081  0 
xt_physdev              6481  0 
xt_policy               7617  8 
xt_multiport            7233  4 
xt_conntrack            6593  0 
ipt_ULOG               11845  0 
ipt_TTL                 6337  0 
ipt_ttl                 5953  0 
ipt_TOS                 6337  0 
ipt_tos                 5825  0 
ipt_TCPMSS              8129  0 
ipt_SAME                6593  0 
ipt_REJECT              9281  4 
ipt_REDIRECT            6209  0 
ipt_recent             14285  0 
ipt_owner               6081  0 
ipt_NETMAP              6209  0 
ipt_MASQUERADE          7745  0 
ipt_LOG                10177  7 
ipt_iprange             5953  0 
ipt_hashlimit          13001  0 
ipt_ECN                 7105  0 
ipt_ecn                 6337  0 
ipt_DSCP                6337  0 
ipt_dscp                5825  0 
ipt_CLUSTERIP          12612  0 
ipt_ah                  5953  0 
ipt_addrtype            5953  0 
ip_nat_irc              6721  0 
ip_nat_tftp             5953  0 
ip_nat_ftp              7361  0 
ip_conntrack_irc       10801  1 ip_nat_irc
ip_conntrack_tftp       8377  1 ip_nat_tftp
ip_conntrack_ftp       11697  1 ip_nat_ftp
iptable_nat            11333  0 
ip_nat                 21485  8 ipt_SAME,ipt_REDIRECT,ipt_NETMAP,ipt_MASQUERADE,ip_nat_irc,ip_nat_tftp,ip_nat_ftp,iptable_nat
ip_conntrack           54177  13 xt_state,xt_CONNMARK,xt_connmark,xt_conntrack,ipt_MASQUERADE,ip_nat_irc,ip_nat_tftp,ip_nat_ftp,ip_conntrack_irc,ip_conntrack_tftp,ip_conntrack_ftp,iptable_nat,ip_nat
nfnetlink              10841  2 ip_nat,ip_conntrack
iptable_mangle          6977  1 
iptable_filter          7105  1 
ip_tables              17157  4 iptable_raw,iptable_nat,iptable_mangle,iptable_filter
x_tables               18117  37 xt_tcpudp,xt_state,xt_pkttype,xt_CLASSIFY,xt_CONNMARK,xt_MARK,xt_length,xt_connmark,xt_physdev,xt_policy,xt_multiport,xt_conntrack,ipt_ULOG,ipt_TTL,ipt_ttl,ipt_TOS,ipt_tos,ipt_TCPMSS,ipt_SAME,ipt_REJECT,ipt_REDIRECT,ipt_recent,ipt_owner,ipt_NETMAP,ipt_MASQUERADE,ipt_LOG,ipt_iprange,ipt_hashlimit,ipt_ECN,ipt_ecn,ipt_DSCP,ipt_dscp,ipt_CLUSTERIP,ipt_ah,ipt_addrtype,iptable_nat,ip_tables
bridge                 51673  0 
ipv6                  246497  22 
autofs4                24773  1 
it87                   23269  0 
hwmon_vid               6721  1 it87
hwmon                   7493  1 it87
i2c_isa                 9409  1 it87
hidp                   24257  2 
l2cap                  30401  5 hidp
bluetooth              53285  2 hidp,l2cap
sunrpc                149245  1 
video                  19525  0 
button                 10705  0 
battery                13381  0 
ac                      8901  0 
lp                     16393  0 
parport_pc             29669  1 
parport                38409  2 lp,parport_pc
ohci_hcd               24157  0 
sis900                 27072  0 
i2c_sis630             11469  0 
mii                     9409  1 sis900
i2c_sis96x              9669  0 
i2c_core               24769  4 it87,i2c_isa,i2c_sis630,i2c_sis96x
serio_raw              11077  0 
r8169                  32585  0 
dm_snapshot            20845  0 
dm_zero                 6081  0 
dm_mirror              25105  0 
dm_mod                 58457  11 dm_snapshot,dm_zero,dm_mirror
raid5                  35137  1 
xor                    18377  1 raid5
ext3                  125641  8 
jbd                    57813  1 ext3
Comment 1 Dave Bradley 2006-08-27 19:07:05 EDT
I attached a serial console and captured the following output:

kernel BUG at net/core/dev.c:1206!
invalid opcode: 0000 [#1]
SMP 
Modules linked in: xt_tcpudp xt_state xt_pkttype iptable_raw xt_CLASSIFY 
xt_CONNMARK xt_MARK xt_length xt_connmark xt_physdev xt_policy xt_multiport 
xt_conntrack ipt_ULOG ipt_TTL ipt_ttl ipt_TOS ipt_tos ipt_TCPMSS ipt_SAME 
ipt_REJECT ipt_REDIRECT ipt_recent ipt_owner ipt_NETMAP ipt_MASQUERADE ipt_LOG 
ipt_iprange ipt_hashlimit ipt_ECN ipt_ecn ipt_DSCP ipt_dscp ipt_CLUSTERIP 
ipt_ah ipt_addrtype ip_nat_irc ip_nat_tftp ip_nat_ftp ip_conntrack_irc 
ip_conntrack_tftp ip_conntrack_ftp iptable_nat ip_nat ip_conntrack nfnetlink 
iptable_mangle iptable_filter ip_tables x_tables bridge ipv6 autofs4 it87 
hwmon_vid hwmon i2c_isa hidp l2cap bluetooth sunrpc video button battery ac lp 
parport_pc parport i2c_sis630 serio_raw sis900 i2c_sis96x mii r8169 i2c_core 
dm_snapshot dm_zero dm_mirror dm_mod raid5 xor ext3 jbd
CPU:    0
EIP:    0061:[<c05af58e>]    Not tainted VLI
EFLAGS: 00210297   (2.6.17-1.2174_FC5xen0 #1) 
EIP is at skb_gso_segment+0x29/0xc9
eax: 00000000   ebx: f20bf424   ecx: 00000180   edx: c066b780
esi: f20bf424   edi: 00000008   ebp: c18ff000   esp: f20bdb54
ds: 007b   es: 007b   ss: 0069
Process smbd (pid: 4153, threadinfo=f20bc000 task=f3256df0)
Stack: <0>f2f26700 f20bf424 00000002 c05b06f5 f20bf424 00000180 00000002 
c18ff000 
       f20bf424 00000000 c18ff180 c05bef18 f20bf424 c18ff000 c1b6ec00 00000000 
       c18ff000 f20bc000 f20bf424 c05b233c c18ff000 f20bf424 f2b81400 f20bf424 
Call Trace:
 <c05b06f5> dev_hard_start_xmit+0x16a/0x1f9  <c05bef18> __qdisc_run+0xde/0x198
 <c05b233c> dev_queue_xmit+0x1be/0x2a2  <f4aaddde> 
br_dev_queue_push_xmit+0xb7/0xbe [bridge]
 <f4aade22> br_forward_finish+0x3d/0x41 [bridge]  <f4aade7b> 
__br_forward+0x55/0x57 [bridge]
 <f4aae89f> br_handle_frame_finish+0xb8/0xd8 [bridge]  <f4aaea4d> 
br_handle_frame+0x18e/0x1a5 [bridge]
 <c05b0310> netif_receive_skb+0x197/0x298  <c05ce0bf> ip_finish_output+0x0/0x17a
 <c05b1e97> process_backlog+0xb0/0x199  <c05b204d> net_rx_action+0xcd/0x1fe
 <c042238b> __do_softirq+0x70/0xef  <c042244a> do_softirq+0x40/0x67
 <c0422789> local_bh_enable+0x6c/0x78  <c05b2419> dev_queue_xmit+0x29b/0x2a2
 <c05cf35c> ip_output+0x1b6/0x1ee  <c05cebf8> ip_queue_xmit+0x374/0x3b3
 <c0404d79> hypervisor_callback+0x3d/0x48  <c05dc31e> 
tcp_transmit_skb+0x5d2/0x602
 <c05ddcaf> __tcp_push_pending_frames+0x6b7/0x789  <c04dbfb7> 
copy_from_user+0x5c/0x90
 <c05d46c4> tcp_sendmsg+0x8ce/0x9ca  <c05a6a19> do_sock_write+0xa3/0xac
 <c05a6ef7> sock_aio_write+0x56/0x63  <c045f265> do_sync_write+0xc0/0xf3
 <c042f167> autoremove_wake_function+0x0/0x3a  <c0474df9> dput+0x35/0x20e
 <c045faf9> vfs_write+0xad/0x136  <c04600d6> sys_write+0x3b/0x64
 <c0404ba7> syscall_call+0x7/0xb 
Code: eb a6 57 56 53 8b 5c 24 10 8b 83 a0 00 00 00 0f b7 7b 76 83 78 10 00 74 
08 0f 0b b5 04 a5 aa 64 c0 8a 43 74 83 e0 0c 3c 04 74 08 <0f> 0b b6 04 a5 aa 64 
c0 8b 83 98 00 00 00 8b 53 20 89 43 24 29 
EIP: [<c05af58e>] skb_gso_segment+0x29/0xc9 SS:ESP 0069:f20bdb54
 <0>Kernel panic - not syncing: Fatal exception in interrupt
 (XEN) Domain 0 crashed: rebooting machine in 5 seconds.
Comment 2 Ville Lindfors 2006-09-20 01:54:40 EDT
Also seems to happen with the next kernel: kernel-xenU-2.6.17-1.2187_FC5
Comment 3 Ville Lindfors 2006-09-20 01:56:30 EDT
Created attachment 136706 [details]
Crash dump
Comment 4 Herbert Xu 2006-09-20 21:06:08 EDT

*** This bug has been marked as a duplicate of 206630 ***

Note You need to log in before you can comment on or make changes to this bug.