Bug 204222 - Password error window popuped by calling "eject" command from remote
Password error window popuped by calling "eject" command from remote
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: eject (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-27 04:04 EDT by nakai
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-28 09:52:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nakai 2006-08-27 04:04:26 EDT
Description of problem:
Error window is popuped when "eject" command (eject-2.1.5-0.1.fc5) is called 
from remote (e.g. via XDMCP or ssh with X-forword)

This popup said "The password you typed is invalid. Please try again."
However, this is clearly wrong because no password was entered for "eject".

Using old version (eject-2.1.2-1.2.1),
"eject" (called from remote) said "eject: unable to open `/dev/hdc'" on terminal.
But, new version (eject-2.1.5-0.1.fc5) returns password error with POPUP-window. 

I think old one's behavior is correct. 


Version-Release number of selected component (if applicable):
 eject-2.1.5-0.1.fc5

How reproducible:  always

Steps to Reproduce:
1. Log in from remote with ssh(X-forwarded) or XDMCP... 
2. Execute "eject" command.
  
Actual results:
A popup-window opens.
It says "The password you typed is invalid. Please try again." (this is wrong)


Expected results:
Don't open a popup.
Some messages shoud be provided on stdout or stderr correctly.
(back to the older behavior)

Additional info:
GKrellM calls "eject -d" command as it starts up.
So, executing "gkrellm" from remote, this popup(password error) opens.
Comment 1 Ngo Than 2006-08-28 09:52:33 EDT
it's fixed in rawhide. I will build new package into FC5-updtae soon. Thanks 
for your report.
Comment 2 nakai 2006-08-29 06:07:40 EDT
I updated eject to 2.1.5-0.2.fc5.
It works as expected.
Thank you for fixing this problem.

Note You need to log in before you can comment on or make changes to this bug.