Bug 204224 - No sound output on Asus A7N8X Deluxe via digital output
Summary: No sound output on Asus A7N8X Deluxe via digital output
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: sndconfig (Show other bugs)
(Show other bugs)
Version: 6
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Martin Stransky
QA Contact:
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-08-27 08:18 UTC by mail@romal.de
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-22 14:32:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log from soundconfig (46.27 KB, text/plain)
2006-08-31 17:32 UTC, mail@romal.de
no flags Details
Log from soundconfig (602 bytes, text/plain)
2006-08-31 17:33 UTC, mail@romal.de
no flags Details
alsa config file (9.01 KB, text/plain)
2006-12-16 12:04 UTC, mail@romal.de
no flags Details

Description mail@romal.de 2006-08-27 08:18:59 UTC
Description of problem:

HW:
NForce 2 Chipset
External soundsystem connected via digital output (copper spdif)
No Sound is generated

Cabling the amplifer via analog produces sound, so the driver is correct, but
the digital output is not activated.

Perhaps an extension to snd-config to try the other output options if the user
clicks "No" after the "Did you hear the sound" dialog would be a viable solution.

Version-Release number of selected component (if applicable):

Rawhide 2006-08-26

How reproducible:

Every Time.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Martin Stransky 2006-08-31 12:33:48 UTC
Could you attach /root/scsrun.log and /root/scsconfig.log?

Comment 2 mail@romal.de 2006-08-31 17:32:52 UTC
Created attachment 135310 [details]
Log from soundconfig

Comment 3 mail@romal.de 2006-08-31 17:33:16 UTC
Created attachment 135311 [details]
Log from soundconfig

Comment 4 mail@romal.de 2006-08-31 17:54:54 UTC
Hi Martin,

I did some digging around.

If I select "NVidia nForce2 - IEC958" system-config-soundcard will play the
testsound.

But all other apps like Totem or Rythmbox still keep silent, so I would guess,
the generated config-file isn't correct. Also when starting
system-config-soundcard a second, it does not seem to remember the selected
pcm-device from the first run.

cu romal


Comment 5 Martin Stransky 2006-10-03 12:45:01 UTC
Could you please check "$aplay -D hw:0,2 /usr/share/sounds/phone.wav"?
You may use "hw:0,2" device instead of the default...

Comment 6 mail@romal.de 2006-10-27 17:10:20 UTC
Hi,

yes, that rings a bell :-)

Sorry, for the delay, I was on vacations (without internet access, grrr).

cu romal

[romal@delos yum.repos.d]$ aplay -D hw:0,2 /usr/share/sounds/phone.wav
Playing WAVE '/usr/share/sounds/phone.wav' : Signed 16 bit Little Endian, Rate
44100 Hz, Stereo
Warning: rate is not accurate (requested = 44100Hz, got = 48000Hz)
         please, try the plug plugin 
[romal@delos yum.repos.d]$ 


Comment 7 Tiger MacClaren 2006-11-05 06:02:31 UTC
i have an NVidia Nforce2 AC97 which is detected properly but in order to get the
sound test to work I have to change the drop-down box to iec958.   but even when
I make the default IEC958 in the settings tab, absolutely no program will play
through the digital speakers.   I tried your aplay -D hw:0,2
/usr/share/sounds/phone.wav  and it did play through the digital speakers.  
What does that mean?  How can we make it default to hw:0,2 for all programs??

Comment 8 Martin Stransky 2006-12-14 13:56:45 UTC
Can you please attach your:

/etc/asound.conf
~/.asoundrc

(if you have them)

It looks like a problem here...

Do you hear a sound via IEC958 if you run this one?

$aplay /usr/share/sounds/phone.wav



Comment 9 mail@romal.de 2006-12-16 12:03:16 UTC
Both files do no exist:

[romal@delos ~]$ su -
Passwort: 
[root@delos ~]# find / -name .asoundrc -print
[root@delos ~]# ls /etc/asound*
/etc/asound.state
[root@delos ~]# find / -name asound* -print
/proc/asound
/usr/share/doc/alsa-lib-devel-1.0.12/doxygen/html/asoundef_8h.html
/usr/share/doc/alsa-lib-devel-1.0.12/doxygen/html/asoundlib_8h.html
/usr/share/doc/alsa-lib-devel-1.0.12/doxygen/html/asoundef_8h-source.html
/usr/share/doc/alsa-lib-devel-1.0.12/doxygen/html/asoundlib_8h-source.html
/usr/share/doc/alsa-lib-1.0.12/asoundrc.txt
/usr/src/kernels/2.6.18-1.2784.fc6-i686/include/sound/asound_fm.h
/usr/src/kernels/2.6.18-1.2784.fc6-i686/include/sound/asoundef.h
/usr/src/kernels/2.6.18-1.2784.fc6-i686/include/sound/asound.h
/usr/src/kernels/2.6.18-1.2798.fc6-i686/include/sound/asound_fm.h
/usr/src/kernels/2.6.18-1.2798.fc6-i686/include/sound/asoundef.h
/usr/src/kernels/2.6.18-1.2798.fc6-i686/include/sound/asound.h
/usr/include/sound/asound_fm.h
/usr/include/sound/asound.h
/usr/include/alsa/asoundef.h
/usr/include/alsa/sound/asound_fm.h
/usr/include/alsa/asoundlib.h
/usr/include/sys/asoundlib.h
/etc/asound.state
[root@delos ~]# 

/etc/asound.state is attached.

aplay /usr/share/sounds/phone.wav does not produce any sound.


Comment 10 mail@romal.de 2006-12-16 12:04:22 UTC
Created attachment 143850 [details]
alsa config file

Comment 11 Martin Stransky 2007-05-22 14:32:13 UTC
Hello,

it's a bug in system-config-soundcard, fixed in FC-7. If you use FC-6, write to
your /etc/asound.conf these lines:

defaults.pcm.card 0 
defaults.pcm.device 2
defaults.ctl.card 0


Note You need to log in before you can comment on or make changes to this bug.