Bug 204229 - Cannot install dictionary extension to Thunderbird unless I am root
Cannot install dictionary extension to Thunderbird unless I am root
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-27 06:32 EDT by Zdeněk Zikán
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-28 11:03:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
filelist of /usr/lib/thunderbird-1.5.0.10 (37.64 KB, text/plain)
2007-05-21 05:14 EDT, Maxim Egorushkin
no flags Details

  None (edit)
Description Zdeněk Zikán 2006-08-27 06:32:40 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. I download dictionary for spellchecking from
http://www.mozilla.com/thunderbird/dictionaries.html (I tried Czech one)
2. I try to install it in Thunderbird. It tells me it was successfully installed
but it does not reflect truth. Even after Thunderbird restart.
3. If I install it under root, it works (even for other users).
  
Actual results: No dictionary installed after this procedure.


Expected results: Dictionary really installed.


Additional info:
$ rpm -q thunderbird
thunderbird-1.5.0.5-1.1.fc5
Comment 1 Konrad 2007-03-30 09:30:23 EDT
Still present with FC6 and thunderbird-1.5.0.10-1.fc6.

Extension installation from unprivileged account proceeds without errors, but
after installation the extension mysteriously disappears from extensions list.
Comment 2 Maxim Egorushkin 2007-05-21 05:03:55 EDT
I'm trying to set up English (GB) spellchecking without any luck.

Tools->Extensions list says English (GB) Language Pack is installed as well as a
dozen of other language packs. Yet Edit->Preferences->Composition->Spelling has
only one language in the language selection drop-down list: English/United
States. All other languages are missing.

Not certain though, it it is the same bug.
Comment 3 Maxim Egorushkin 2007-05-21 05:14:50 EDT
Created attachment 155079 [details]
filelist of /usr/lib/thunderbird-1.5.0.10

This is a filelist of /usr/lib/thunderbird-1.5.0.10 which shows language packs
installed. None of the installed languages can be selected in
Edit->Preferences->Composition->Spelling->Language
Comment 4 Maxim Egorushkin 2007-05-21 05:21:28 EDT
Script from https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=202403 solved
my problem.
Comment 5 Matěj Cepl 2007-07-18 13:32:57 EDT
Fedora Core 5 is no longer supported, could you please reproduce this with the
updated version of the currently supported distribution (Fedora Core 6, or
Fedora 7, or Rawhide)? If this issue turns out to still be reproducible, please
let us know in this bug report.  If after a month's time we have not heard back
from you, we will have to close this bug as CANTFIX.

Setting status to NEEDINFO, and awaiting information from the reporter.

Thanks in advance.
Comment 6 Matěj Cepl 2007-08-28 11:03:22 EDT
We haven't got any reply to the last question about reproducability of the bug
with Fedora Core 6, Fedora 7, or Fedora devel. Mass closing this bug, so if you
have new information that would help us fix this bug, please reopen it with the
additional information.
Comment 7 Zdeněk Zikán 2007-08-28 11:43:25 EDT
Sorry for the late reply. I've tested it now on Fedora 7 with all updates
installed and it works fine. You can close the bug.

Note You need to log in before you can comment on or make changes to this bug.