Bug 2042666 - SELinux is preventing atril-thumbnail from 'write' accesses on the sock_file bus.
Summary: SELinux is preventing atril-thumbnail from 'write' accesses on the sock_file ...
Keywords:
Status: CLOSED DUPLICATE of bug 2042696
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 35
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Zdenek Pytela
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:f144c4f35f40cc78e53a46f496a...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-01-19 21:32 UTC by Manoel Miranda
Modified: 2022-01-20 16:21 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-01-20 16:21:58 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Manoel Miranda 2022-01-19 21:32:25 UTC
Description of problem:
SELinux is preventing atril-thumbnail from 'write' accesses on the sock_file bus.

*****  Plugin catchall (100. confidence) suggests   **************************

Se você acredita nisso atril-thumbnail deve ser permitido write acesso no bus sock_file por padrão.
Then você deve informar que este é um erro.
Você pode gerar um módulo de política local para permitir este acesso.
Do
permitir este acesso por agora executando:
# ausearch -c 'atril-thumbnail' --raw | audit2allow -M my-atrilthumbnail
# semodule -X 300 -i my-atrilthumbnail.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:session_dbusd_tmp_t:s0
Target Objects                bus [ sock_file ]
Source                        atril-thumbnail
Source Path                   atril-thumbnail
Port                          <Desconhecido>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
SELinux Policy RPM            selinux-policy-targeted-35.10-1.fc35.noarch
Local Policy RPM              selinux-policy-targeted-35.10-1.fc35.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 5.15.14-200.fc35.x86_64 #1 SMP Tue
                              Jan 11 16:49:27 UTC 2022 x86_64 x86_64
Alert Count                   2
First Seen                    2022-01-18 18:52:20 -03
Last Seen                     2022-01-19 18:30:00 -03
Local ID                      24565953-de5b-4df0-9810-cc9c736a1d9a

Raw Audit Messages
type=AVC msg=audit(1642627800.193:450): avc:  denied  { write } for  pid=8144 comm="gdk-pixbuf-thum" name="bus" dev="tmpfs" ino=54 scontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:session_dbusd_tmp_t:s0 tclass=sock_file permissive=0


Hash: atril-thumbnail,thumb_t,session_dbusd_tmp_t,sock_file,write

Version-Release number of selected component:
selinux-policy-targeted-35.10-1.fc35.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.15.2
hashmarkername: setroubleshoot
kernel:         5.15.14-200.fc35.x86_64
type:           libreport

Comment 1 Zdenek Pytela 2022-01-20 16:21:58 UTC

*** This bug has been marked as a duplicate of bug 2042696 ***


Note You need to log in before you can comment on or make changes to this bug.