Bug 204279 - Suggestion about Hangul/Hanja convertion.
Suggestion about Hangul/Hanja convertion.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: scim-hangul (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Akira TAGOH
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-28 03:49 EDT by Jong Bae KO
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-30 04:58:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
new feature in scim-0.3.1 (19.09 KB, image/png)
2007-03-30 02:06 EDT, sangu
no flags Details

  None (edit)
Description Jong Bae KO 2006-08-28 03:49:56 EDT
Description of problem:
Hangul/Hnaja convertion is working well.
If Hangul char is already in there and you want to convert it.
Now only Hangul/Hanja converting function supports in pre-editing state(a cursor
on a character) eg. If you type 한글(gksrmf), you only can convert "글" because
"한"  is out of pre-editing state. If you want to convert "한" later, you have
to type "한" again.

ps. Windows supports this function.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 sangu 2007-03-30 02:06:08 EDT
Created attachment 151255 [details]
new feature in scim-0.3.1

scim-hangul-0.3.1(using libhangul) provides this feature ( bug 204279 ).

in rawhide (20070329).
scim-hangul-0.3.1-1.fc7
libhangul-0.0.4-2.fc7
Comment 2 Jong Bae KO 2007-03-30 02:12:21 EDT
Oh. This is a good news
Thanks Sangu.
Comment 3 Akira TAGOH 2007-03-30 04:58:41 EDT
I guess it may be unlikely to enter libhangul into FC6 and to appear newer
scim-hangul, because it requires additional dependency. moving this bug to devel
and closing.

Note You need to log in before you can comment on or make changes to this bug.