Bug 20429 - Cannot make RPM 3.0.5 installable RPMs with RPM 4.0
Cannot make RPM 3.0.5 installable RPMs with RPM 4.0
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-06 11:59 EST by Shane Painter
Modified: 2007-04-18 12:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-16 20:26:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shane Painter 2000-11-06 11:59:01 EST
No backwards compatability was included with RPM 4.0 with regards to 
building RPMs. One must use 6.2 (RPM 3.0.5) to build RPMs that can be 
installed on 6.2SBE2. There is no option to RPM 4.0 to build 
3.0.5 'comlpiant' RPMs. This makes it very inconvenient to build RPMs that 
are designed for both 7.0 and 6.2.
Comment 1 Jeff Johnson 2000-12-16 20:26:03 EST
Soon to be released rpm-4.0.1 will build version 3 packages if --nodirtokens is
specified on the command line. However, since rpm-4.0.1 will be released for all
Red Hat releases, there will be little
need for the facility in a short period of time.
Comment 2 Jeff Johnson 2000-12-22 10:32:36 EST
rpm-4.0.1 includes the ability to produce version3 packaging. FWIW, the problem
of building a single package for both Red Hat 6.x and 7.x is much more
complicated
in general than just the version number of the packaging.

Note You need to log in before you can comment on or make changes to this bug.